summaryrefslogtreecommitdiff
path: root/dev-python/google-api-python-client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-08 11:11:23 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-08 11:11:23 +0000
commit909e6f36d5376b253aba44edc8f2af1a5acd0c11 (patch)
tree048569e21e5eb27492bcd1fa73bbc1cc462b3ce5 /dev-python/google-api-python-client
parentac778f2cf394586c43beb5d753a19ff3f6063556 (diff)
gentoo auto-resync : 08:12:2023 - 11:11:23
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest2
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.110.0.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 3c5888d88061..b2c37f89ea31 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,5 +1,7 @@
DIST google-api-python-client-2.108.0.tar.gz 12227437 BLAKE2B 7b8023f0e940730539bbfed2c213f6ec007b4e838eb87d8c7bd037c5f6dd73cbf97cdb6cec869d10f4c0135ff2989e1fa0b6a4b51cc118e7be2e45e2488d3b76 SHA512 baff038d8161de7150ac877dcca3af8a7f38fc9cfcdae9e70bdaf877f11fa35f572102ec1b6eda47a24f26386638285fc0ff31fbeb185d9174a40ca90cf20ba3
DIST google-api-python-client-2.109.0.tar.gz 12264648 BLAKE2B b0ff31b5e770f38ac44569a3480a9d0a28988441a907c823be7603fd3a48a5d407aeafdc6de5e8cadf32693f3363f0231f82e692fdeabe1ceb42eaeb5c99595b SHA512 1e5cd06a49548536b53411aa247f9118e808b97dd4b110f614347329f148ba9bc89514e5c205c7e7a90f52c53ab944a3a16afa833dc4a458d9ab53dc093bad63
+DIST google-api-python-client-2.110.0.tar.gz 12416779 BLAKE2B 4b8bf928262db5d66d3201aaa2541cfd2ea9c5276528a8cee285eaafbb6947419d40c7335c3b131b9208e4a5c9c1e3c5df695bdd66a0a8b5736ea79d24ae1547 SHA512 a100b2a33c2944b8c5044c40cfdee4911e44fc1b366d4fd66cd99fd35c47058113f89c952b24d47b4ac3db573be30af1351d9b4e0d10b69e1ef5c5e5499f891b
EBUILD google-api-python-client-2.108.0.ebuild 1313 BLAKE2B 93f5dbf9054531a2a9275f71bd7732e16cc9b510302c00677a8b1d1092ec8d4f81cf119e67cf4b2f623763e722f36038cf28f373fe1990d635e38f17e87c1b54 SHA512 6316da593c211dae45147c5ba1cb6a65898da75668978dfe13fb6eaa9d3ff7bf6e35d01aa1cf0c3249b5e6c240cf5f23252223feefe40ec3e2d650103e340248
EBUILD google-api-python-client-2.109.0.ebuild 1316 BLAKE2B d6d158b0cdd8c45d8d79dbc2977291d7e3342c7f53da3adcb227708ae8f3161413381d971dddf63b941a32b94133a6cd4c661d7b76863a5d3162db0495fdceaa SHA512 762a1b2c0e8c06f60e01fd9045abc4255999039a97e86145bdbe8ea7727d2bbfd3defd6c6e932a726f0efe001cb0364d1640f2a808c531ff57ec66d8740d9d13
+EBUILD google-api-python-client-2.110.0.ebuild 1316 BLAKE2B d6d158b0cdd8c45d8d79dbc2977291d7e3342c7f53da3adcb227708ae8f3161413381d971dddf63b941a32b94133a6cd4c661d7b76863a5d3162db0495fdceaa SHA512 762a1b2c0e8c06f60e01fd9045abc4255999039a97e86145bdbe8ea7727d2bbfd3defd6c6e932a726f0efe001cb0364d1640f2a808c531ff57ec66d8740d9d13
MISC metadata.xml 538 BLAKE2B bf0b8ab3a89ce9ab1d2159f4c0ebfe3f2646aced20bd2006485510c12d22e83cc130fac979f699ae6431a610c8d2acf86c04b39bc262abaf167c20571a860810 SHA512 30d004d944055660165954f8475e57ba45cef56423c80a324118836d78e5376261409955155a40c9bd988f230f3e2fc44c6aeb6fae3028c78c55a382ccd83bff
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.110.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.110.0.ebuild
new file mode 100644
index 000000000000..0194f9640998
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.110.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ epytest tests
+}