summaryrefslogtreecommitdiff
path: root/dev-python/google-api-python-client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-04-16 08:45:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2025-04-16 08:45:29 +0100
commit79851ef7da5ffce7aed667c8c49a1ce04333619e (patch)
treed02a27f205d4bf84ecc872e84d0580f49708a86c /dev-python/google-api-python-client
parentdfd0139069bb79941b882fe714d38b7fc8dcdb16 (diff)
gentoo auto-resync : 16:04:2025 - 08:45:29
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest2
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.167.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 5130fc15df93..335bd5ebe949 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,3 +1,5 @@
DIST google_api_python_client-2.166.0.tar.gz 12680525 BLAKE2B 3b05b2d18da5a20e74a798738e48385e3fe85297f3a1b106624c948a1ef48b4a90e955bb8c75c3381d30a7c370ded63eb931769dfc4d09406913499fc03325c4 SHA512 cb41e2f3968da6b87f6bad2c66410cfbb5ab86d20b0b0713660a5e3aefecd2ede7015d136784d31c6af1dcdbbeacc8ca24cdc9c22b9799c271bb1bdfe6179f71
+DIST google_api_python_client-2.167.0.tar.gz 12725129 BLAKE2B d1d94b92f161f68ccad986eb17043a9f1855357cc8914b9a58755f6eb9451c3768012a68d45709f0a79e70936734ff8f1464dcbc19b7ba1bdff88eca54a881fa SHA512 ae51ef8985d87f0663ce34d5bc28c29693268fdf362b95ad1d8c6c5aa847c6880082d0b25281d6c7dda91b7a17eb62057deeccd31e9416309a50f04c6ff33e09
EBUILD google-api-python-client-2.166.0.ebuild 1455 BLAKE2B 753e47ac06d5790f890e4e5c8b50f2ecbaa6ec0c6b51ee4dd8ac472c927fd60cc47f0458304325ef91bfd110d9af4bc5f89365e6949cc62243e5bf112f0591e9 SHA512 ffb14b186d2976c3af821bf9b34218eebf26271b8730e7e55e7c8f8f182a1944569da43fe831c8e6639b3f82ad833d3dc1c4290f95f3ac553c24c74b8e13eb28
+EBUILD google-api-python-client-2.167.0.ebuild 1458 BLAKE2B abc96ed5fc57035f36cdf6723758169539e99033baac0226f9d02b91417806bab2fced58aae6fa0c9530b787375c16ff6bf92145e325ed96d3f7124c34986924 SHA512 b3a9f6c444f98007488fbd795ae9adc9aaf16d51dcd761527aa819385840ee1c4a0bdb76f36e896f841c1e0203e0f1c406582f98c2e38c072ab1f9e8efdaf9bb
MISC metadata.xml 538 BLAKE2B bf0b8ab3a89ce9ab1d2159f4c0ebfe3f2646aced20bd2006485510c12d22e83cc130fac979f699ae6431a610c8d2acf86c04b39bc262abaf167c20571a860810 SHA512 30d004d944055660165954f8475e57ba45cef56423c80a324118836d78e5376261409955155a40c9bd988f230f3e2fc44c6aeb6fae3028c78c55a382ccd83bff
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.167.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.167.0.ebuild
new file mode 100644
index 000000000000..f4f4a9c95e9b
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.167.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ tests/test_discovery.py::Universe::test_client_options_universe_configured_with_mtls
+ tests/test_discovery.py::Universe::test_universe_env_var_configured_with_mtls
+ )
+
+ epytest tests
+}