summaryrefslogtreecommitdiff
path: root/dev-python/google-api-python-client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-04 20:01:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-04 20:01:09 +0000
commit3daf38ec350b4e25244c69eea165b18afd090459 (patch)
tree5489bd5abdccd746fe68e98b9164e887bfbcfde4 /dev-python/google-api-python-client
parent84bfe2244c544bae8dcaffbaf4cfb80f59f88f64 (diff)
gentoo auto-resync : 04:01:2024 - 20:01:09
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest2
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.112.0.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 125fceb9cb7d..7dd3b5fb1ff4 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,3 +1,5 @@
DIST google-api-python-client-2.111.0.tar.gz 12461105 BLAKE2B 3aa1de35867fbf2287fc4f0aadf4dc77aeb62bc0d894bcaf546ca00e062de289c83a732298ad6b09927d60bb1e3ea47e0a20fb108e23cb7af222e67a6e45d464 SHA512 3eb9a4580c6b59dbd7dff1f0ca9f309e92d7f75ce6d3085833d96c72751212a47073ef2b322ad85bc2795e82c85b9b80593f18a7335cc7438b0acaa94cbf04f5
+DIST google-api-python-client-2.112.0.tar.gz 12465562 BLAKE2B d29c22176fb3467c7df0d937baa954973437fc03862b56a370888fe014b24e3ec1b8b1c00b80251bcd039711340aea13bd21618f782ee4bd7c975c0820271630 SHA512 e9bbec1c27105cb772c1f059b5cf2f83cf44f1aa003149a509cac15c46d68c80edd2705aad597f31d98e31cb61396f0516ddc69b5041237d96246898c31329b4
EBUILD google-api-python-client-2.111.0.ebuild 1313 BLAKE2B 93f5dbf9054531a2a9275f71bd7732e16cc9b510302c00677a8b1d1092ec8d4f81cf119e67cf4b2f623763e722f36038cf28f373fe1990d635e38f17e87c1b54 SHA512 6316da593c211dae45147c5ba1cb6a65898da75668978dfe13fb6eaa9d3ff7bf6e35d01aa1cf0c3249b5e6c240cf5f23252223feefe40ec3e2d650103e340248
+EBUILD google-api-python-client-2.112.0.ebuild 1316 BLAKE2B 437ad4346d43d1a71c6ca6537c57e42b7b50fc5bd71d69157abad0e24bda38d6f07ff192b146304a689a8040392a4ee5c50ad11da5b7f512cde4675502aea379 SHA512 4e68eed9dbadc5b5298b8d883d98ffd290fdbf96a0ed0ad8064751fe2823fc7c49117fb4676f09bbb9a1ebb72af43876023ec8b01729962256b477c0db839d0f
MISC metadata.xml 538 BLAKE2B bf0b8ab3a89ce9ab1d2159f4c0ebfe3f2646aced20bd2006485510c12d22e83cc130fac979f699ae6431a610c8d2acf86c04b39bc262abaf167c20571a860810 SHA512 30d004d944055660165954f8475e57ba45cef56423c80a324118836d78e5376261409955155a40c9bd988f230f3e2fc44c6aeb6fae3028c78c55a382ccd83bff
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.112.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.112.0.ebuild
new file mode 100644
index 000000000000..c041dee86d3c
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.112.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ epytest tests
+}