summaryrefslogtreecommitdiff
path: root/dev-python/google-api-python-client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-03 08:13:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-03 08:13:59 +0100
commit2df2e0ebc717aa53904c920c1a361423dfc3a5f7 (patch)
treed81b257b3923100dc55a999dd12b2198a6d35b99 /dev-python/google-api-python-client
parent75abd8d3830449158bdd27f9c4701bcbadc55080 (diff)
gentoo auto-resync : 03:04:2024 - 08:13:58
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest2
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.125.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 8cb4f1d4df3f..44250237b493 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,5 +1,7 @@
DIST google-api-python-client-2.122.0.tar.gz 11884905 BLAKE2B e22e9cc1b7e2afebbf0a1793e4d2c96d7e3d4b38e7266213d57b8db2eeedcc6c37a18bd0cc62c50fa84221dfea2bfc1ebd9c0cbe33fe4921662e50dd26ccde5d SHA512 dc17be212b975d700ca8ea333d0b1b7207f48cd870190154e14b94d5ae3f835c8f1fe63ed1ac267b1a1ab8a6916a6d55c479d5728801bbc74f842231eef71049
DIST google-api-python-client-2.124.0.tar.gz 11956565 BLAKE2B efa7273bb4c298804b331ea29218710a7427e614f830fe308763ef226ec392f3f1ea16e4d0f4f5ff98c987eba7c9331f0ff0ed6d32a89e9538d1fa18fcc40399 SHA512 4eacdbe4733a235b5c31c337c8cde18fef88691d55a8b988291dd5ff8cea786f67b4052eb2fb6e7aeb31631311f956e255469c3a1438f137c1eb03b43812f9c9
+DIST google-api-python-client-2.125.0.tar.gz 12020305 BLAKE2B a5c5beef66a40adc8eb9b56476bbd2eb6a5b9b1b528ccbfa964d9a2c65bdff2f949c52de5384faae6c7233be6f3357040a8fe531e0d21f48f822276a8e8a7ec9 SHA512 b2f456edacf515f83755bfaeb35677c3d3f6bef90d4d9be986a9191c3e8a0d80664784cc125524dd77792a329ff58fc9b35b0bd387248450a8b4e67ccaaa2f85
EBUILD google-api-python-client-2.122.0.ebuild 1313 BLAKE2B 31fc929d21fb567d5d6b9fad785a3881f152e618cd61abe50e834d10c13332a52a6c9990826447b0431b56a246e80e9cf0d3f007b997f2a675fda25f49332bde SHA512 53680ecc0febe6f1747965a70b56242656d4e86216a24e0b3d56c9768f9315594ffcb41558a823f905cb6ea720cf7ece227ecbf0c3141b76d039c3a011b2746f
EBUILD google-api-python-client-2.124.0.ebuild 1483 BLAKE2B 5ddedf1b929c9fdb108af436d7a99985456d1ee7bc044771ebba57e793adbbfb45a04e4e8f43b7498c8f1829e6be40385c3a71146087210ed96fb755be9b1a24 SHA512 30bae0af2da28d840afd050f4615fe31be6f6aece394e8f1f4d4ea431c18f11b50baefedde5c7a661d06e9804f25bf3110237aa058df86789de470807207070d
+EBUILD google-api-python-client-2.125.0.ebuild 1483 BLAKE2B 5ddedf1b929c9fdb108af436d7a99985456d1ee7bc044771ebba57e793adbbfb45a04e4e8f43b7498c8f1829e6be40385c3a71146087210ed96fb755be9b1a24 SHA512 30bae0af2da28d840afd050f4615fe31be6f6aece394e8f1f4d4ea431c18f11b50baefedde5c7a661d06e9804f25bf3110237aa058df86789de470807207070d
MISC metadata.xml 538 BLAKE2B bf0b8ab3a89ce9ab1d2159f4c0ebfe3f2646aced20bd2006485510c12d22e83cc130fac979f699ae6431a610c8d2acf86c04b39bc262abaf167c20571a860810 SHA512 30d004d944055660165954f8475e57ba45cef56423c80a324118836d78e5376261409955155a40c9bd988f230f3e2fc44c6aeb6fae3028c78c55a382ccd83bff
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.125.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.125.0.ebuild
new file mode 100644
index 000000000000..3961663be4b6
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.125.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ tests/test_discovery.py::Universe::test_client_options_universe_configured_with_mtls
+ tests/test_discovery.py::Universe::test_universe_env_var_configured_with_mtls
+ )
+
+ epytest tests
+}