summaryrefslogtreecommitdiff
path: root/dev-python/google-api-python-client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-08 18:16:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-08 18:16:35 +0000
commit2237cda0c6b012952e02ec1314e1f48eddf4dab7 (patch)
tree0a7ab76265dc441f4b3436f07d019007e6a13237 /dev-python/google-api-python-client
parent6a57f9ee53dc794f3d47ea68f78d6ef76d00af47 (diff)
gentoo auto-resync : 08:01:2023 - 18:16:34
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.71.0-r1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 42f322e63865..9ca649f4e2c9 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -3,5 +3,6 @@ DIST google-api-python-client-2.70.0.gh.tar.gz 37420341 BLAKE2B 8bc148c2cfeb1be5
DIST google-api-python-client-2.71.0.gh.tar.gz 37887241 BLAKE2B 5b0e8f39a4935f6e64e1846b7457e2fef62f91d8b62debd277dd49fe28242ffa6d1f8bf8962b56860448aa0edd8fe23d102062809995b212b775c760d20b403c SHA512 a13e31226991a77f900e87f72232d6722dc34d3b7a0134fed3039a5439d207ee26a3f9caa8b4cc5319acc864e11f07e080c0cea25ff29ab1a775b49278582c83
EBUILD google-api-python-client-2.68.0.ebuild 1442 BLAKE2B f386901776c1845ec0815ba4254b5e6cdbeec0c7dab8a3928bb60a6259ef1140bd4e3ece4287fc3ea0e1833a69cb8432fa973447f83846e60b6a6b2038bfbb20 SHA512 828e71b82de37f6d50f980e897c0cf5a46df036dcfa005906aed6772455c8f5059c1fa6bcf0b2340fb9307df08df2789e6421e26b5c0ff28774844c3a36c828c
EBUILD google-api-python-client-2.70.0.ebuild 1444 BLAKE2B 4bd33fb2b9ec7d091d0b8e5aadbc24c5c786d4adf497087e749364f74f54536db99cd9efc6ade89b333e60ac09220badf45e721fca040227a53f151ee197b131 SHA512 4a3be7d069bf83dba8a7911ce9ed5761e1fe2c78dacb94a921aea897a0ba201b5c58983de5a487f841f498501b7e2ea7a5bdefad29a518fd75e546ff3c10925e
+EBUILD google-api-python-client-2.71.0-r1.ebuild 1439 BLAKE2B 9c0f725d19df30b792d44e65ec2220afc2b475370fdea43436787eb9b8d32b8b8fb2ebced9207a3a6cd880d0571f4373f079bc4e17a0bddc45ad1ef31a200989 SHA512 5fabbb0362e61e102d11536b900b99debb8053ab397f795a2e9e2f17ea342e4b3e97191d464c1a1683844ed16935df019de1e9221db32f9fccd7eb39f9535e3b
EBUILD google-api-python-client-2.71.0.ebuild 1444 BLAKE2B 83f05fc39ec4a3a0048df114068d4c4aad4a6361a8bdc7c8d83f55fe2f925795f343c31941622e60654d179a5b6d7064017926e67ae27e17c461d6a472d3c618 SHA512 91fe171a68bac4e641c2a36b9e1133d6292bcb5adc9753f765da800b0528f96f1f2f6e77b919843e3a2d0c7b5b8abcf4f524c11db12e7d8f9b5c1d4204e23a54
MISC metadata.xml 538 BLAKE2B bf0b8ab3a89ce9ab1d2159f4c0ebfe3f2646aced20bd2006485510c12d22e83cc130fac979f699ae6431a610c8d2acf86c04b39bc262abaf167c20571a860810 SHA512 30d004d944055660165954f8475e57ba45cef56423c80a324118836d78e5376261409955155a40c9bd988f230f3e2fc44c6aeb6fae3028c78c55a382ccd83bff
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.71.0-r1.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.71.0-r1.ebuild
new file mode 100644
index 000000000000..73c0eee57b5d
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.71.0-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_10 )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+SRC_URI="
+ https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ epytest tests
+}