summaryrefslogtreecommitdiff
path: root/dev-python/google-api-python-client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-13 00:08:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-13 00:08:30 +0100
commit0ebcd2cbf178600b5eb36b2f24cdbb3d2f4a9000 (patch)
tree941e6ba8c256dd27e9f9ca634f08d4bf0278798e /dev-python/google-api-python-client
parentf0ddcad13515f66d2f3bf827d33c277bdba7e1dd (diff)
gentoo auto-resync : 13:06:2024 - 00:08:29
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest2
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.133.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index feb31159454e..c3fe7c703f9b 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,5 +1,7 @@
DIST google-api-python-client-2.130.0.tar.gz 11178249 BLAKE2B 8f89f85124f72fa1c23ef6ab2d8e0eba2935ae14bf3528102de977aeec6b6b525f51f6d6d574e582b010ad49f6d8ac450cdf6edae7653a6b47b15868754e6ea4 SHA512 3553a140a86974cbf05cf21b4792f59adb3dee23e50772c8b6d285868ef08566bda8a64895b7054fa3f340dac0c9f52b4a712eba3fabea8feebca7390149e0ed
DIST google-api-python-client-2.132.0.tar.gz 11256536 BLAKE2B 4a046c03a50b3922b94e6a07bfce974851752542a69300d544b7c8439c4ad54fc9fd2d5fdf84656801ebe9bf5ad35588d39dc3603537d67db93ea995b50651ff SHA512 ecd6be9009f979447ee7d29dc05af2b25c500ca17a8d88ae6660ac0a72f6bb8237f3224dda63b22378a38c6cf7fab914bc6372351d95e691c3b16f248be04a64
+DIST google-api-python-client-2.133.0.tar.gz 11299741 BLAKE2B d964eebe1ce76448d716865f200b07f06eeffac866aa40f602a8bae09cdfd0f66ec6eec8d96f71a63d8cbad68c4677c7398f0b7157507b8f56b04210debe937a SHA512 a22871af52b0a40b328328438c248b324d5f695f507df2df470ef6735b7d3b7261915d087d8260dc315a57c7a12825412cc1a468170c8b77a74fbc0523858952
EBUILD google-api-python-client-2.130.0.ebuild 1475 BLAKE2B d19c13ce0fe0968d44016c0c7b2a023f393c31af0758473d6996d06b87cf1c950757f442ac4a0d2f460f848ca45cc3b185d92eedf81249d63204b2c2b952096e SHA512 1c58462ddc1ed7da0d7130fda6daf0e6df229d5de9b99a6b9fd44489827554254025389543b40f7db725ce537ffc85c51551ea9512d4abefb02bade4613050b9
EBUILD google-api-python-client-2.132.0.ebuild 1478 BLAKE2B 4660fef51f05bc038cb079a4680f3cb5ce0fb8b6c0cbe609470d5a3e1106eb76da26fb969040e8eaa250581513a96fabc09b66b32641441707ab741ef9732ee8 SHA512 152bb175cb77bb8bec3da99cea918d8b2ad709d2f5ea671c30181b04a3ffb26656ccf8fa9301132019fb47f81253411ae7612e9c7271d3cb0d0d4ea6df9bc163
+EBUILD google-api-python-client-2.133.0.ebuild 1478 BLAKE2B 4660fef51f05bc038cb079a4680f3cb5ce0fb8b6c0cbe609470d5a3e1106eb76da26fb969040e8eaa250581513a96fabc09b66b32641441707ab741ef9732ee8 SHA512 152bb175cb77bb8bec3da99cea918d8b2ad709d2f5ea671c30181b04a3ffb26656ccf8fa9301132019fb47f81253411ae7612e9c7271d3cb0d0d4ea6df9bc163
MISC metadata.xml 538 BLAKE2B bf0b8ab3a89ce9ab1d2159f4c0ebfe3f2646aced20bd2006485510c12d22e83cc130fac979f699ae6431a610c8d2acf86c04b39bc262abaf167c20571a860810 SHA512 30d004d944055660165954f8475e57ba45cef56423c80a324118836d78e5376261409955155a40c9bd988f230f3e2fc44c6aeb6fae3028c78c55a382ccd83bff
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.133.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.133.0.ebuild
new file mode 100644
index 000000000000..224056fade87
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.133.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ tests/test_discovery.py::Universe::test_client_options_universe_configured_with_mtls
+ tests/test_discovery.py::Universe::test_universe_env_var_configured_with_mtls
+ )
+
+ epytest tests
+}