summaryrefslogtreecommitdiff
path: root/dev-python/google-api-python-client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-19 06:30:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-19 06:30:51 +0000
commitf8bb2d659372d0add11c589dcb006d0b7f8822ae (patch)
tree5d64f4f593db363260360200660abcd8ff00d1c6 /dev-python/google-api-python-client
parentf57e008aa126ccdca95f7424e4d24a1a83a49682 (diff)
gentoo auto-resync : 19:12:2024 - 06:30:51HEADmaster
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest2
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.156.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 09a9ec52a4f5..1615916e80c3 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,5 +1,7 @@
DIST google_api_python_client-2.154.0.tar.gz 12070143 BLAKE2B 91b2838116246e04fc93a155fb27792a2efa6e258eeddf29989c62229db7975b389435efeb6342d069358797539c57ea630c7bf7da64a0cdef7ceb4801586a85 SHA512 9728f4cda59919ddec28876f27b6e7716d96c9ba08088f064aa1ac0e0a4ccd1d7ad66e592ac8e2429f04520b64d8228fd3d358f7ae7d157048c9719fcb7b8cd3
DIST google_api_python_client-2.155.0.tar.gz 12195015 BLAKE2B f9c82244881b131dd022b7fd817c9fae28d4be6c6a1410e5e674d050e66b1361182515b6a220eef988ab4fdfa62e4cbf13de58e699672b3382a5449380c422e9 SHA512 1b2101d93178aa0507dcb2d8fb70c0ec29d547b87a7572508f56c87f8877b6c795f494c7f7f020df72d9e2b96083d135dfddd0ad80bb9d317189598fca9192f8
+DIST google_api_python_client-2.156.0.tar.gz 12230345 BLAKE2B 9ce77dc4fd962bf24a8046678c4c21501218dd1f3a356b364bb6940f564f9aa7e6d99c77db9b5e7fea271a17b10726a668f07dec6ec344bad5cad98a1975a107 SHA512 c29debb48f8504eb6316ec465613e87b083429344a9e74f4f52d07f6edf47b017a7f0b539557de4ca575ead3dda1d4b0579faf483102fab407c15386277d5078
EBUILD google-api-python-client-2.154.0.ebuild 1455 BLAKE2B 0c236e102819fa393880129e1ae048cce4a018e567de29e2d344a451a87dd0f261b05b5285ed660f8b36937cf0b2503eef3fee84ef7e64c3754269f5878a45bd SHA512 b2dc3d562f94b8ffc4c6b6fecbf7538fe676f1a8667e71886585231e0fa3ac2d1e0269d8afc3879f94e3c328faf99672bea5109275527236afc79e7b46fdbe1a
EBUILD google-api-python-client-2.155.0.ebuild 1458 BLAKE2B de0b7e7284c45a3a6eabbe54d470e5f216b867e16271dcc0535533bf53683c634faacb3ecf5a21589336e75ff85ab3dbcc9011085dea646df2008a72b162f009 SHA512 2c627f313081d9d186b7a75bcaa8fec68e75ed8ab4ff8f76ac3db2808b8e1ae20cace68afd4e02479c55016bf83aad38edbadea7e4cc78f61dc8f9c91813e114
+EBUILD google-api-python-client-2.156.0.ebuild 1458 BLAKE2B de0b7e7284c45a3a6eabbe54d470e5f216b867e16271dcc0535533bf53683c634faacb3ecf5a21589336e75ff85ab3dbcc9011085dea646df2008a72b162f009 SHA512 2c627f313081d9d186b7a75bcaa8fec68e75ed8ab4ff8f76ac3db2808b8e1ae20cace68afd4e02479c55016bf83aad38edbadea7e4cc78f61dc8f9c91813e114
MISC metadata.xml 538 BLAKE2B bf0b8ab3a89ce9ab1d2159f4c0ebfe3f2646aced20bd2006485510c12d22e83cc130fac979f699ae6431a610c8d2acf86c04b39bc262abaf167c20571a860810 SHA512 30d004d944055660165954f8475e57ba45cef56423c80a324118836d78e5376261409955155a40c9bd988f230f3e2fc44c6aeb6fae3028c78c55a382ccd83bff
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.156.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.156.0.ebuild
new file mode 100644
index 000000000000..58a0eb467bad
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.156.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ tests/test_discovery.py::Universe::test_client_options_universe_configured_with_mtls
+ tests/test_discovery.py::Universe::test_universe_env_var_configured_with_mtls
+ )
+
+ epytest tests
+}