summaryrefslogtreecommitdiff
path: root/dev-python/google-api-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-02 00:00:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-02 00:00:17 +0100
commitf5ef7f2371babf22c2c3fad17108692b09e4c98e (patch)
tree7f195ab30a74fa23e6dd24307d67d0890714d093 /dev-python/google-api-core
parent3d12b65aa1b4bb8b02b1f8d3e77bccf230b79a09 (diff)
gentoo auto-resync : 02:05:2024 - 00:00:17
Diffstat (limited to 'dev-python/google-api-core')
-rw-r--r--dev-python/google-api-core/Manifest2
-rw-r--r--dev-python/google-api-core/google-api-core-2.19.0.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/google-api-core/Manifest b/dev-python/google-api-core/Manifest
index af9deb6ed3d9..b31da8846d9f 100644
--- a/dev-python/google-api-core/Manifest
+++ b/dev-python/google-api-core/Manifest
@@ -1,3 +1,5 @@
DIST python-api-core-2.18.0.gh.tar.gz 210938 BLAKE2B 39ccceb2d5722cb4121ba2007cb171e703e97c57d31dd85a6f540f8b0316281255f563b43c1acd6159e6d59b8609603ca9202c9f46b5c86127a9ff0cf3874c19 SHA512 fe57eb8465c1dfe6d83abd73b0c621da49e7e0687afa59f5d4c1c7022cb8a912734859e5895781c239cfe6053ebdbea2dcf55ef6eac371b8ea58fdf0c7c398d5
+DIST python-api-core-2.19.0.gh.tar.gz 210832 BLAKE2B 89947f8e8bda6de96c1778788e72f88c85d7781c4bf3c7fa08b67cd0e9b40e5774a57a5772add9c724a1bddab9ad514ddc605035289466a5648393ca57854321 SHA512 e8fb94428c3d49dcf760a0b9a471fa7fe3d149ebb11f8c12c16a0f68aaf736c5a8553d628834b4456d2419c40cc30010449ae58026271c32bbd32f67857ba31b
EBUILD google-api-core-2.18.0.ebuild 1981 BLAKE2B 987067bd69c908f475ccc11f594fce1f8bea834a0e8cef91b030c7e4b19cb8a3250a7b50b678c4cca02548a3d3b011cf224507ff27dc12b405d1d86b6e4e65e7 SHA512 dcbe8bfef5b1ac9dbb5c1f8e33858b9065cda05ab735f2a3f0b96dafb534be0faceaa3dd143f1e0f1a1e1d84d0847752a9fdb7976a162eb43bc7f6df986cbeb1
+EBUILD google-api-core-2.19.0.ebuild 1984 BLAKE2B 5f2d0e1451977c2d1c86240d0d124bbaded178e9f4453a3c92ccd80faddd276b2791ed65d2d924acb0a755e86401cb7626e3b25c06b0a38f486120f71afde758 SHA512 dfe3490f1e4498b8e5ca8d9907448d9d21232a39f850f3945cd5eaccc91527ee0bed4d3a49741fc32977818b14fa61fcb19b49f91fc5bd722d2a5b1af8f099a3
MISC metadata.xml 519 BLAKE2B bf6ee9b3f0f7fe5fbfa5461aabf7872c803bd0483938da629ed6468017d82ac5b8736a52ef325374d7948a752ff1cfa6006aca2e833721f5a4a47f4adc5d8630 SHA512 d56b0312f5e5b5ba909c84af358bbfea98ea4098fbdd0ab562e0669a87a492facc05644d13fc38a196e1300f4cc1638b28cdcd10f412d753d71f8cf20a7fec62
diff --git a/dev-python/google-api-core/google-api-core-2.19.0.ebuild b/dev-python/google-api-core/google-api-core-2.19.0.ebuild
new file mode 100644
index 000000000000..b3d3b179c62a
--- /dev/null
+++ b/dev-python/google-api-core/google-api-core-2.19.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=python-api-core-${PV}
+DESCRIPTION="Core Library for Google Client Libraries"
+HOMEPAGE="
+ https://github.com/googleapis/python-api-core/
+ https://pypi.org/project/google-api-core/
+ https://googleapis.dev/python/google-api-core/latest/index.html
+"
+SRC_URI="
+ https://github.com/googleapis/python-api-core/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/googleapis-common-protos-1.56.2[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.25.0[${PYTHON_USEDEP}]
+ >=dev-python/proto-plus-1.22.3[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.19.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ !dev-python/namespace-google
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # failing due to missing grpcio-status
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_unary_errors
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_raised
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_read
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_aiter
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_write
+ tests/unit/test_grpc_helpers.py::test_wrap_unary_errors
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_invocation
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_iterator_initialization
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_during_iteration
+)
+
+python_test() {
+ rm -rf google || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio tests
+}