summaryrefslogtreecommitdiff
path: root/dev-python/google-api-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-02 22:17:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-02 22:17:13 +0100
commitec321939a77843497c860196ea06d7776d94b755 (patch)
tree426c3b59f57bfb684b461e65c4416048b369b4ce /dev-python/google-api-core
parent2982504d287f7f91eade76902f11e691f8181071 (diff)
gentoo auto-resync : 02:09:2022 - 22:17:13
Diffstat (limited to 'dev-python/google-api-core')
-rw-r--r--dev-python/google-api-core/Manifest2
-rw-r--r--dev-python/google-api-core/google-api-core-2.10.0.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/google-api-core/Manifest b/dev-python/google-api-core/Manifest
index 26d36d22add5..5e90fc7b1a95 100644
--- a/dev-python/google-api-core/Manifest
+++ b/dev-python/google-api-core/Manifest
@@ -1,3 +1,5 @@
+DIST python-api-core-2.10.0.gh.tar.gz 180767 BLAKE2B 1f8d86fbd39c6bed927b2354c7e734ef2de563e2583bc4d9bff8121ae45b5538c67472a723e6c6990d1c5aa165ea83e3c1184fae2fd79ce2ea985aa89e057c7a SHA512 e4719eee37e04719d6ce7d0fe99e106ffdc8fba08f73d02f94b597f7c6fa4e57a0e28876b1c5baa2a9ce77220422f17d234b0d802d63238217a902fab65d546c
DIST python-api-core-2.8.2.gh.tar.gz 164586 BLAKE2B bd62b20d1be52f0a2227d1663ee37ce31d991e0773ed793a3999b70c74e03a28ac188cc331027def0055a5b80e93378d9ec5baa389c65e7d2f183b37233be5ac SHA512 5844339cee71103650c446f002dcb13a632086d96dec1ed04a0ad5e4d3a61cc2a8e048da3e6445a50a0c009b0d25729f02865d28484bfee2a3427c829537e350
+EBUILD google-api-core-2.10.0.ebuild 2118 BLAKE2B 6a5f079686f99d6714db73d9061bf0ffbad66fa30101871663496018430b5e09db6405ef864ae79e5ff240d8d27d14f30ec9b5aa9969f6f7f8c54263d5aa31f7 SHA512 6e6ba79577c17242f63dc16bfd3f5bbcd976492411a8f170faf5d1ab81948897d71731d9b289f97d6c73942052288949d609e9f8657a7f67fa0d733c4701a311
EBUILD google-api-core-2.8.2.ebuild 2116 BLAKE2B 2de96b01871de23ecede06ab214e606d22fae01fb2f4f57a1ac1568f2a6044e898022df1c0311dd3e5b7a23af6c8a917b713e45de399914c1bb1573b2a54c880 SHA512 e203f44aa72c910a49ab836c45aa2766f428f89563333401169e181d4f273853512608c8938f949855a0bbfebe576b3965af5cf985b43ab360202c3a1a6f7112
MISC metadata.xml 453 BLAKE2B b53e834b3c423d8bdceaa2568f38173fc203f92f2340edd42899e4d4a93602118dbdb2283d492e34189155c336ec659d96f907f257b34cbe5557be331169a4f5 SHA512 d26c893b82fa946cab27669148b3dc2dea8b985636209ae49294cb14a7055f6c4a3884b38bce6e4923a54e9872af7e540b33a992eb727caae96e071a8ffe3237
diff --git a/dev-python/google-api-core/google-api-core-2.10.0.ebuild b/dev-python/google-api-core/google-api-core-2.10.0.ebuild
new file mode 100644
index 000000000000..1f782b73aa45
--- /dev/null
+++ b/dev-python/google-api-core/google-api-core-2.10.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=python-api-core-${PV}
+DESCRIPTION="Core Library for Google Client Libraries"
+HOMEPAGE="
+ https://github.com/googleapis/python-api-core/
+ https://pypi.org/project/google-api-core/
+ https://googleapis.dev/python/google-api-core/latest/index.html
+"
+SRC_URI="
+ https://github.com/googleapis/python-api-core/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/googleapis-common-protos-1.56.2[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.25.0[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.20.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ !dev-python/namespace-google
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/proto-plus[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # failing due to missing grpcio-status
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_unary_errors
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_raised
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_read
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_aiter
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_write
+ tests/unit/test_grpc_helpers.py::test_wrap_unary_errors
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_invocation
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_iterator_initialization
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_during_iteration
+)
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+src_test() {
+ rm -r google || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ distutils_write_namespace google
+ epytest -p no:aiohttp -p no:trio tests
+}