summaryrefslogtreecommitdiff
path: root/dev-python/google-api-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-python/google-api-core
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-python/google-api-core')
-rw-r--r--dev-python/google-api-core/Manifest4
-rw-r--r--dev-python/google-api-core/google-api-core-2.3.0.ebuild50
-rw-r--r--dev-python/google-api-core/google-api-core-2.3.1.ebuild50
3 files changed, 104 insertions, 0 deletions
diff --git a/dev-python/google-api-core/Manifest b/dev-python/google-api-core/Manifest
index d1434c463b6c..00c4759ea95f 100644
--- a/dev-python/google-api-core/Manifest
+++ b/dev-python/google-api-core/Manifest
@@ -1,3 +1,7 @@
DIST google-api-core-2.2.2.tar.gz 140701 BLAKE2B 4e90db4311fc88d3fc8e29d6d8f11ae1424000c0e293f219d679984ec4a2c1bbbaf72d734b937d6916302f3a9a8b1cb369dd719972f4eb2d3f7264bf16ffbc7f SHA512 9b307c8ebd224b7614bd1d9f48d752852929b726c04df24f81e0b1b601f9a14d10654e9ef53b6a5ab677e8e57256f87b8683fa4dde0585f9c2e6d313d29d53fe
+DIST google-api-core-2.3.0.tar.gz 155449 BLAKE2B 4aba324a18c8b6f9b9afd223688771fc6a57ee71f550736cfb5c9fac861a6a84369eb4e6ebec0664241590624c52cd0bcc8762afeb230debc16f0849fde049bf SHA512 f85c9279822ab818aa9d183bc930e61be9cfb2e65ab6a46fcd8aaab2531b4258c6247b02fb8f4f29841d9ab13ca33e129198589cbc37b3c77677a72e72635285
+DIST google-api-core-2.3.1.tar.gz 156495 BLAKE2B fdc7f7d8457b96947181eee9992c5e51bbd18f9740a0415a32d4d0f45ade9c0c784e01f0aa78fe0dbbf3717ee860e78d6b4d1c5f154361afbf919abe033e5380 SHA512 ab1c333727e666f920d81186e6213d440052021d952efcb47eac487d10ab33a2e1116278925e54bfb3468de70c18837a0e241ba3426af09728ea59a725789a29
EBUILD google-api-core-2.2.2.ebuild 1505 BLAKE2B 0d4d6b99d01c7759d419b61ce5abb74fe338d4972e191ee655bcd47667463a4a736382f1e3a6204618703afd56013441b45bae319b1937993c7a2a02c0e7edd5 SHA512 e75bb724fb988b313a80b6fa34f3e5afc452dc1b1212020ba992603d7206cc19b04657a6654ea494b5e575185dd7c143cfa12bb882614091a18f7deb5c0199b4
+EBUILD google-api-core-2.3.0.ebuild 1507 BLAKE2B acbb86b23d9904ce223d3576848d88659d92b5baeee57cf3cc67b7b9c33ee16d7a8e7428c35a8812de5d88fe55c36bcee0bd66a3c8015a0779b552da7b86ad60 SHA512 f576d7da20f9a87b9239284d2900a653430c7e15e441fc04fbd51851e485a1fddc24db6f555666cb6141f0a744ba7ae289040b1c319fc31a987c13fa8d89870c
+EBUILD google-api-core-2.3.1.ebuild 1507 BLAKE2B acbb86b23d9904ce223d3576848d88659d92b5baeee57cf3cc67b7b9c33ee16d7a8e7428c35a8812de5d88fe55c36bcee0bd66a3c8015a0779b552da7b86ad60 SHA512 f576d7da20f9a87b9239284d2900a653430c7e15e441fc04fbd51851e485a1fddc24db6f555666cb6141f0a744ba7ae289040b1c319fc31a987c13fa8d89870c
MISC metadata.xml 453 BLAKE2B b53e834b3c423d8bdceaa2568f38173fc203f92f2340edd42899e4d4a93602118dbdb2283d492e34189155c336ec659d96f907f257b34cbe5557be331169a4f5 SHA512 d26c893b82fa946cab27669148b3dc2dea8b985636209ae49294cb14a7055f6c4a3884b38bce6e4923a54e9872af7e540b33a992eb727caae96e071a8ffe3237
diff --git a/dev-python/google-api-core/google-api-core-2.3.0.ebuild b/dev-python/google-api-core/google-api-core-2.3.0.ebuild
new file mode 100644
index 000000000000..f67642816e93
--- /dev/null
+++ b/dev-python/google-api-core/google-api-core-2.3.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Core Library for Google Client Libraries"
+HOMEPAGE="https://github.com/googleapis/python-api-core/
+ https://googleapis.dev/python/google-api-core/latest/index.html"
+SRC_URI="https://github.com/googleapis/${PN//google/python}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P//google/python}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/googleapis-common-protos[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.25.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+"
+# grpcio support is broken if grpcio-status is not installed,
+# and we do not package the latter
+BDEPEND="
+ test? (
+ !!dev-python/grpcio
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+
+EPYTEST_DESELECT=(
+ # TODO: package proto-plus
+ tests/unit/test_protobuf_helpers.py::test_field_mask_ignore_trailing_underscore
+ tests/unit/test_protobuf_helpers.py::test_field_mask_ignore_trailing_underscore_with_nesting
+)
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}
diff --git a/dev-python/google-api-core/google-api-core-2.3.1.ebuild b/dev-python/google-api-core/google-api-core-2.3.1.ebuild
new file mode 100644
index 000000000000..f67642816e93
--- /dev/null
+++ b/dev-python/google-api-core/google-api-core-2.3.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Core Library for Google Client Libraries"
+HOMEPAGE="https://github.com/googleapis/python-api-core/
+ https://googleapis.dev/python/google-api-core/latest/index.html"
+SRC_URI="https://github.com/googleapis/${PN//google/python}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P//google/python}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/googleapis-common-protos[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.25.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+"
+# grpcio support is broken if grpcio-status is not installed,
+# and we do not package the latter
+BDEPEND="
+ test? (
+ !!dev-python/grpcio
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+
+EPYTEST_DESELECT=(
+ # TODO: package proto-plus
+ tests/unit/test_protobuf_helpers.py::test_field_mask_ignore_trailing_underscore
+ tests/unit/test_protobuf_helpers.py::test_field_mask_ignore_trailing_underscore_with_nesting
+)
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}