summaryrefslogtreecommitdiff
path: root/dev-python/google-api-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-08 11:11:23 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-08 11:11:23 +0000
commit909e6f36d5376b253aba44edc8f2af1a5acd0c11 (patch)
tree048569e21e5eb27492bcd1fa73bbc1cc462b3ce5 /dev-python/google-api-core
parentac778f2cf394586c43beb5d753a19ff3f6063556 (diff)
gentoo auto-resync : 08:12:2023 - 11:11:23
Diffstat (limited to 'dev-python/google-api-core')
-rw-r--r--dev-python/google-api-core/Manifest2
-rw-r--r--dev-python/google-api-core/google-api-core-2.15.0.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/google-api-core/Manifest b/dev-python/google-api-core/Manifest
index 8e24d1f8e960..d4d127f96a92 100644
--- a/dev-python/google-api-core/Manifest
+++ b/dev-python/google-api-core/Manifest
@@ -1,3 +1,5 @@
DIST python-api-core-2.14.0.gh.tar.gz 192103 BLAKE2B f1b05d3218392125600d113f35a726ada2f3247fca2fdce05f3a6419fe60bf59df8a3724fdd62d9047e55ecb39071527265fe86ba181f09e1bb5940b4b7dd4ba SHA512 a7641595f25d163b44906139df80e3581d52fb1078b70ec9b9a55583e148d82b51cfe3f710d04b776c7b038ef8c57b9b1119284711100e9681ee6f81b0ac6b58
+DIST python-api-core-2.15.0.gh.tar.gz 193916 BLAKE2B 708bee6e62b4049d88bc88dfc03add6496ee1861954485e145ab01707284216aef224bd8646a3336417d8b114a8c196ce44e8da63e53c3dff3d616ff9bef25ad SHA512 1abbeb266e4bcb9cf8a2dc6ba795a5667b5e9a870fe8609335e929ac17410822e4324d88c7692f8c60534e9ee4b0933af0277cc44ccb2d805bcbaf8db1288bba
EBUILD google-api-core-2.14.0.ebuild 2145 BLAKE2B f289fc4cdb99d2fb5d23ee9b6657c47d403b51db871541f371ba465227b4ba3270cdb2d4ba392edbf7b17055436fd5fcc548fd388a4b6da7cad6d85236e9f18c SHA512 1d9e0454f365966dc798e69bb6c98b4965ec5a66104d923b8cff479c53ec3ff1711dfd8c84df02fb30312dacea58b09b4bea87cee937dde5c86fdaf5d6308a37
+EBUILD google-api-core-2.15.0.ebuild 1976 BLAKE2B 5c032a7015ff570729ec31f210da0e5df07b79096a1ae10dc956920f8ee00959b7729a96325ef4e52d87836760b47317764c5994d1c87e3d5d24cba826cacc19 SHA512 3a4c25456a0e115c6e6500faa20462110b0c40a56375987cda262522555ec916773b9d85d37609003bc4f8e9bf77044c47106b3f8d2f54cd6e04be3180bdcf4f
MISC metadata.xml 519 BLAKE2B bf6ee9b3f0f7fe5fbfa5461aabf7872c803bd0483938da629ed6468017d82ac5b8736a52ef325374d7948a752ff1cfa6006aca2e833721f5a4a47f4adc5d8630 SHA512 d56b0312f5e5b5ba909c84af358bbfea98ea4098fbdd0ab562e0669a87a492facc05644d13fc38a196e1300f4cc1638b28cdcd10f412d753d71f8cf20a7fec62
diff --git a/dev-python/google-api-core/google-api-core-2.15.0.ebuild b/dev-python/google-api-core/google-api-core-2.15.0.ebuild
new file mode 100644
index 000000000000..45e4a27798d6
--- /dev/null
+++ b/dev-python/google-api-core/google-api-core-2.15.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=python-api-core-${PV}
+DESCRIPTION="Core Library for Google Client Libraries"
+HOMEPAGE="
+ https://github.com/googleapis/python-api-core/
+ https://pypi.org/project/google-api-core/
+ https://googleapis.dev/python/google-api-core/latest/index.html
+"
+SRC_URI="
+ https://github.com/googleapis/python-api-core/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/googleapis-common-protos-1.56.2[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.25.0[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.19.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ !dev-python/namespace-google
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/proto-plus[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # failing due to missing grpcio-status
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_unary_errors
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_raised
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_read
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_aiter
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_write
+ tests/unit/test_grpc_helpers.py::test_wrap_unary_errors
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_invocation
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_iterator_initialization
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_during_iteration
+)
+
+python_test() {
+ rm -rf google || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio tests
+}