summaryrefslogtreecommitdiff
path: root/dev-python/google-api-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-22 07:00:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-22 07:00:36 +0000
commit267b3b848468a603048b181330ee73cf0bd99c44 (patch)
treed48682864ec3b9a40741db3604455fbc723465b2 /dev-python/google-api-core
parent58d5ec1c1e98326577fa902f6c9c568639b18d12 (diff)
gentoo auto-resync : 22:03:2024 - 07:00:36
Diffstat (limited to 'dev-python/google-api-core')
-rw-r--r--dev-python/google-api-core/Manifest2
-rw-r--r--dev-python/google-api-core/google-api-core-2.18.0.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/google-api-core/Manifest b/dev-python/google-api-core/Manifest
index 9ef429afac33..225cb5935d7f 100644
--- a/dev-python/google-api-core/Manifest
+++ b/dev-python/google-api-core/Manifest
@@ -1,3 +1,5 @@
DIST python-api-core-2.17.1.gh.tar.gz 209222 BLAKE2B 8a851388268953897d6bef6a072adac4d539459af7f64db609ccb9ce8b91f617d3bfd8a8dc3fa6433107e70ca9f8ef441fe8f717fc4905a57e621871bbc8cac1 SHA512 7381723c64b5e145f88b7e01b510c64e222088df3a9c4ce6ddbd0c491d44514c12dc61bdd67d78391c0d6c247e9e1a0f092b7e04a9222fc96b6360e95b48f157
+DIST python-api-core-2.18.0.gh.tar.gz 210938 BLAKE2B 39ccceb2d5722cb4121ba2007cb171e703e97c57d31dd85a6f540f8b0316281255f563b43c1acd6159e6d59b8609603ca9202c9f46b5c86127a9ff0cf3874c19 SHA512 fe57eb8465c1dfe6d83abd73b0c621da49e7e0687afa59f5d4c1c7022cb8a912734859e5895781c239cfe6053ebdbea2dcf55ef6eac371b8ea58fdf0c7c398d5
EBUILD google-api-core-2.17.1.ebuild 1973 BLAKE2B 75f487287c02e16dfdedbb4462cacdb7500185c26ca64a7812a46cf3189782e8a316636a60c03691fa232b6cb6ad3061e80b25f55d88ab16cea721210c4ab7e3 SHA512 543cbfa78c1042bb57c7c467f712f0f92ba9fd726ed569409252121d72c838f98e987fda878de35b0b13cd07ce0a2847ef88a38782a58832669a9e7261d5a236
+EBUILD google-api-core-2.18.0.ebuild 1984 BLAKE2B 5f2d0e1451977c2d1c86240d0d124bbaded178e9f4453a3c92ccd80faddd276b2791ed65d2d924acb0a755e86401cb7626e3b25c06b0a38f486120f71afde758 SHA512 dfe3490f1e4498b8e5ca8d9907448d9d21232a39f850f3945cd5eaccc91527ee0bed4d3a49741fc32977818b14fa61fcb19b49f91fc5bd722d2a5b1af8f099a3
MISC metadata.xml 519 BLAKE2B bf6ee9b3f0f7fe5fbfa5461aabf7872c803bd0483938da629ed6468017d82ac5b8736a52ef325374d7948a752ff1cfa6006aca2e833721f5a4a47f4adc5d8630 SHA512 d56b0312f5e5b5ba909c84af358bbfea98ea4098fbdd0ab562e0669a87a492facc05644d13fc38a196e1300f4cc1638b28cdcd10f412d753d71f8cf20a7fec62
diff --git a/dev-python/google-api-core/google-api-core-2.18.0.ebuild b/dev-python/google-api-core/google-api-core-2.18.0.ebuild
new file mode 100644
index 000000000000..b3d3b179c62a
--- /dev/null
+++ b/dev-python/google-api-core/google-api-core-2.18.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=python-api-core-${PV}
+DESCRIPTION="Core Library for Google Client Libraries"
+HOMEPAGE="
+ https://github.com/googleapis/python-api-core/
+ https://pypi.org/project/google-api-core/
+ https://googleapis.dev/python/google-api-core/latest/index.html
+"
+SRC_URI="
+ https://github.com/googleapis/python-api-core/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/googleapis-common-protos-1.56.2[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.25.0[${PYTHON_USEDEP}]
+ >=dev-python/proto-plus-1.22.3[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.19.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ !dev-python/namespace-google
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # failing due to missing grpcio-status
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_unary_errors
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_raised
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_read
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_aiter
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_write
+ tests/unit/test_grpc_helpers.py::test_wrap_unary_errors
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_invocation
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_iterator_initialization
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_during_iteration
+)
+
+python_test() {
+ rm -rf google || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio tests
+}