summaryrefslogtreecommitdiff
path: root/dev-python/google-api-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-26 11:27:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-26 11:27:54 +0100
commit25e2c97a4a6f12a367115508fc86d34fe76a6f5e (patch)
tree68acc191d796190f572dc374002717fec321e616 /dev-python/google-api-core
parent1aa38370b2506ce90ad64cd4e18968d6612ebea5 (diff)
gentoo auto-resync : 26:09:2023 - 11:27:54
Diffstat (limited to 'dev-python/google-api-core')
-rw-r--r--dev-python/google-api-core/Manifest2
-rw-r--r--dev-python/google-api-core/google-api-core-2.12.0.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/google-api-core/Manifest b/dev-python/google-api-core/Manifest
index ce7a86c393a5..74bb6873d549 100644
--- a/dev-python/google-api-core/Manifest
+++ b/dev-python/google-api-core/Manifest
@@ -1,3 +1,5 @@
DIST python-api-core-2.11.1.gh.tar.gz 187982 BLAKE2B 095b96b50f0723543acf32e4db092a8b24eccf68088229668f7f36aa0d29f66905ea8c43d7ca4a4ee4179664b6bb63c45e4619d621a99f8c2a81a4b3dd61c25e SHA512 a2ca8a2a136fd29999662201af462b45da07c0e4d124649bba12d0564c595ebf02bd398354394d7eb4116c875b2c72b29280ee5a770a6773254accc979eacbbe
+DIST python-api-core-2.12.0.gh.tar.gz 189439 BLAKE2B e2186ea64a36f6c59f5771efc20b050aeb6c17a346c005f64658ac0840a7c11f46a375ae796ea3e084ae711a07776b4bb4683e0bab7f10ade0ac132c4e73d22b SHA512 aae4dbe6a935626224280e180f07937595b3dc0a2649b70415fb5ad6df73af26bcb486c7bfc4c01a9ae4b1513b7df2e127aa4cbbf370366ba00dc7b58b884e83
EBUILD google-api-core-2.11.1.ebuild 2146 BLAKE2B 5b7c8c41d53844f9876c90507d344a08074e1fef4eb6b28e012b1658ed24bea72ff5531378e5fb9bb92b3e37df554b78caad0e2f84f03957e5c79110e00b39fe SHA512 94f68362286761ce11e393e10619f8526565eb4b74f85e4c921883351dd16474eb36529239c61f79360db3dc27c04423124039af8cbe47d77e8645b876e47fce
+EBUILD google-api-core-2.12.0.ebuild 2148 BLAKE2B adcaf01ff1d3f5487c07286c8e16ec9436a012afe4f8ab0e4d423f17a7a1845d4359d9f29910d9e5c1a4399f87d38db037777d311b6e828976be77d526292ca4 SHA512 2f19647743d720fb0ed774cabb2850fb384051ec381c6bd5c3322d560e8d8185584a1a65fac1db619106a5492dbe575ba40a3947ea598df0fb15f4f39e21e920
MISC metadata.xml 519 BLAKE2B bf6ee9b3f0f7fe5fbfa5461aabf7872c803bd0483938da629ed6468017d82ac5b8736a52ef325374d7948a752ff1cfa6006aca2e833721f5a4a47f4adc5d8630 SHA512 d56b0312f5e5b5ba909c84af358bbfea98ea4098fbdd0ab562e0669a87a492facc05644d13fc38a196e1300f4cc1638b28cdcd10f412d753d71f8cf20a7fec62
diff --git a/dev-python/google-api-core/google-api-core-2.12.0.ebuild b/dev-python/google-api-core/google-api-core-2.12.0.ebuild
new file mode 100644
index 000000000000..31097fa5f234
--- /dev/null
+++ b/dev-python/google-api-core/google-api-core-2.12.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=python-api-core-${PV}
+DESCRIPTION="Core Library for Google Client Libraries"
+HOMEPAGE="
+ https://github.com/googleapis/python-api-core/
+ https://pypi.org/project/google-api-core/
+ https://googleapis.dev/python/google-api-core/latest/index.html
+"
+SRC_URI="
+ https://github.com/googleapis/python-api-core/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/googleapis-common-protos-1.56.2[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.25.0[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.19.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ !dev-python/namespace-google
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/proto-plus[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # failing due to missing grpcio-status
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_unary_errors
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_raised
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_read
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_aiter
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_write
+ tests/unit/test_grpc_helpers.py::test_wrap_unary_errors
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_invocation
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_iterator_initialization
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_during_iteration
+)
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+src_test() {
+ rm -r google || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ distutils_write_namespace google
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio tests
+}