summaryrefslogtreecommitdiff
path: root/dev-python/google-api-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-07 22:21:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-07 22:21:54 +0000
commit06dcf64674a43718324bffee383625d2cd050b75 (patch)
tree4de58e857f3f0718fef4fc386e42577c2f4c9478 /dev-python/google-api-core
parent198bd0cd3c1be97f7deb5283fa00048718482de4 (diff)
gentoo auto-resync : 07:11:2023 - 22:21:54
Diffstat (limited to 'dev-python/google-api-core')
-rw-r--r--dev-python/google-api-core/Manifest2
-rw-r--r--dev-python/google-api-core/google-api-core-2.13.0.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/google-api-core/Manifest b/dev-python/google-api-core/Manifest
index 664225fdeb47..c094a8954702 100644
--- a/dev-python/google-api-core/Manifest
+++ b/dev-python/google-api-core/Manifest
@@ -1,3 +1,5 @@
DIST python-api-core-2.12.0.gh.tar.gz 189439 BLAKE2B e2186ea64a36f6c59f5771efc20b050aeb6c17a346c005f64658ac0840a7c11f46a375ae796ea3e084ae711a07776b4bb4683e0bab7f10ade0ac132c4e73d22b SHA512 aae4dbe6a935626224280e180f07937595b3dc0a2649b70415fb5ad6df73af26bcb486c7bfc4c01a9ae4b1513b7df2e127aa4cbbf370366ba00dc7b58b884e83
+DIST python-api-core-2.13.0.gh.tar.gz 190862 BLAKE2B 1b979113a93ee3424125713fab38a66f62ff24db7010c235a0631a1cad1f8c617c084e90662c480b17a3ab11857b0b851244e6142ef2cd05266e690f45785daf SHA512 2852813ba959e3a75cc23dfc365eb7e1b335523ae1e0c3b1b30a9f10b4a060f4293f88db0189d5e03f35acd24f23b3c7ae7f657bf4c6f0d3b043a8271f2872c6
EBUILD google-api-core-2.12.0.ebuild 2146 BLAKE2B 5b7c8c41d53844f9876c90507d344a08074e1fef4eb6b28e012b1658ed24bea72ff5531378e5fb9bb92b3e37df554b78caad0e2f84f03957e5c79110e00b39fe SHA512 94f68362286761ce11e393e10619f8526565eb4b74f85e4c921883351dd16474eb36529239c61f79360db3dc27c04423124039af8cbe47d77e8645b876e47fce
+EBUILD google-api-core-2.13.0.ebuild 2148 BLAKE2B adcaf01ff1d3f5487c07286c8e16ec9436a012afe4f8ab0e4d423f17a7a1845d4359d9f29910d9e5c1a4399f87d38db037777d311b6e828976be77d526292ca4 SHA512 2f19647743d720fb0ed774cabb2850fb384051ec381c6bd5c3322d560e8d8185584a1a65fac1db619106a5492dbe575ba40a3947ea598df0fb15f4f39e21e920
MISC metadata.xml 519 BLAKE2B bf6ee9b3f0f7fe5fbfa5461aabf7872c803bd0483938da629ed6468017d82ac5b8736a52ef325374d7948a752ff1cfa6006aca2e833721f5a4a47f4adc5d8630 SHA512 d56b0312f5e5b5ba909c84af358bbfea98ea4098fbdd0ab562e0669a87a492facc05644d13fc38a196e1300f4cc1638b28cdcd10f412d753d71f8cf20a7fec62
diff --git a/dev-python/google-api-core/google-api-core-2.13.0.ebuild b/dev-python/google-api-core/google-api-core-2.13.0.ebuild
new file mode 100644
index 000000000000..31097fa5f234
--- /dev/null
+++ b/dev-python/google-api-core/google-api-core-2.13.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=python-api-core-${PV}
+DESCRIPTION="Core Library for Google Client Libraries"
+HOMEPAGE="
+ https://github.com/googleapis/python-api-core/
+ https://pypi.org/project/google-api-core/
+ https://googleapis.dev/python/google-api-core/latest/index.html
+"
+SRC_URI="
+ https://github.com/googleapis/python-api-core/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/googleapis-common-protos-1.56.2[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.25.0[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.19.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ !dev-python/namespace-google
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/proto-plus[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # failing due to missing grpcio-status
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_unary_errors
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_raised
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_read
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_aiter
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_write
+ tests/unit/test_grpc_helpers.py::test_wrap_unary_errors
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_invocation
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_iterator_initialization
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_during_iteration
+)
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+src_test() {
+ rm -r google || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ distutils_write_namespace google
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio tests
+}