summaryrefslogtreecommitdiff
path: root/dev-python/gnuplot-py/gnuplot-py-1.8-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/gnuplot-py/gnuplot-py-1.8-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/gnuplot-py/gnuplot-py-1.8-r1.ebuild')
-rw-r--r--dev-python/gnuplot-py/gnuplot-py-1.8-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/gnuplot-py/gnuplot-py-1.8-r1.ebuild b/dev-python/gnuplot-py/gnuplot-py-1.8-r1.ebuild
new file mode 100644
index 000000000000..dd6977fde737
--- /dev/null
+++ b/dev-python/gnuplot-py/gnuplot-py-1.8-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_SINGLE_IMPL=true
+
+inherit distutils-r1
+
+DESCRIPTION="A python wrapper for Gnuplot"
+HOMEPAGE="http://gnuplot-py.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc ppc64 ~s390 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc"
+
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ sci-visualization/gnuplot"
+
+DOCS=( ANNOUNCE.txt CREDITS.txt FAQ.txt NEWS.txt TODO.txt )
+
+PATCHES=( "${FILESDIR}"/${PN}-1.7-mousesupport.patch )
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/Gnuplot/. )
+ distutils-r1_python_install_all
+}
+# testsuite does NOT run unattended, so left out here