summaryrefslogtreecommitdiff
path: root/dev-python/gnome-python-extras-base
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /dev-python/gnome-python-extras-base
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'dev-python/gnome-python-extras-base')
-rw-r--r--dev-python/gnome-python-extras-base/Manifest2
-rw-r--r--dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3-r1.ebuild11
2 files changed, 8 insertions, 5 deletions
diff --git a/dev-python/gnome-python-extras-base/Manifest b/dev-python/gnome-python-extras-base/Manifest
index e62b76e79998..faff0fab659b 100644
--- a/dev-python/gnome-python-extras-base/Manifest
+++ b/dev-python/gnome-python-extras-base/Manifest
@@ -1,4 +1,4 @@
AUX gnome-python-extras-base-2.25.3-python-libs.patch 2243 BLAKE2B 05e6d4383c91237fe248afbbe3e04f111b60f3119bcddb99c72adeb671c973379c6c241bdf184dc9dc81b67e347582f631dad175ca39036a3fe2a3f415a659fa SHA512 f9ddacdcffaaf6933e3ab28f843892a4754677a29987d512ebc3810245fb793f8a242b479e47fd63dc7756c817a510e04cda2548aa6bb4d88ce4649c2b1759ed
DIST gnome-python-extras-2.25.3.tar.bz2 370489 BLAKE2B 9ca41f953ed75009f732c811372a560a1fcaf8e81bf4187117c40e61009296df62ed413cfc47194329bb92053762748cd14c3849d0f4a0fe7ccfff8ad72c3529 SHA512 6994b8b5d6ccc009edc7ddfad373b9164d8162f1007972652f6086dca30cac6941ab68ef467d15c972ab05c4ae0e19ec72edc2643636d22a01a3f5a719251467
-EBUILD gnome-python-extras-base-2.25.3-r1.ebuild 1307 BLAKE2B 3628d40a09589ef1acee78bf632b2337503c3c26cab23dcb5c014aaa5870d0ec12d77b6d034cc89ed3b3c8327f8cc3961f13fe6b5161d1b36ee5bf6ba1342acc SHA512 a82a22c5edb1049e12d5c4bbd137f7e560293bcb9d5813ecea0754c9a95c02c405599d13363afddbffd3919cfe202cc5ec30a22063203d1e401fbeb4e59e2410
+EBUILD gnome-python-extras-base-2.25.3-r1.ebuild 1322 BLAKE2B a8c08c9ee2475f2c65ac63a6b92fd356ea7d81f14348970c2d3048b4bb8ed80d96247a9165d4a3b0b5dd0609ba9be829ca403e0664f42316b6196e062716d82b SHA512 f859ccc1dc575c792ed3e7f791f9196111b327dc372127ca603b92b20106ee91d7d2f4d7afebb1dabbab1e1b7dae7ec351a42fd69e7a7f79e5b742ead77246b3
MISC metadata.xml 346 BLAKE2B 48d899b0b769e7edf07feeb6349bd66595360a1fd09a3c9bc5385485729eba9f1eb462e508e6691fe47dd571be396a29fa266fc998cc8d2ff772b353713fcda9 SHA512 e7e631f5ebe3a81d0431366152d6f7a2d21958a031746d6b2fd6ac9ef3f145d78fb30d1014b0912e9d720b3be7c6d2fdc544bb840a9f12fddf37ffdcf65933bd
diff --git a/dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3-r1.ebuild b/dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3-r1.ebuild
index cfcd4a3af74e..bbf4fe11e0d6 100644
--- a/dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3-r1.ebuild
+++ b/dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3-r1.ebuild
@@ -1,19 +1,20 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
PYTHON_COMPAT=( python2_7 )
-inherit versionator autotools eutils gnome2 python-any-r1
+inherit autotools eapi7-ver eutils gnome2 python-r1
# This ebuild does nothing -- we just want to get the pkgconfig file installed
MY_PN="gnome-python-extras"
DESCRIPTION="Provides python the base files for the Gnome Python Desktop bindings"
HOMEPAGE="http://pygtk.org/"
-PVP="$(get_version_component_range 1-2)"
+PVP="$(ver_cut 1-2)"
SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP}/${MY_PN}-${PV}.tar.bz2"
IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
LICENSE="LGPL-2.1"
SLOT="0"
RESTRICT="test"
@@ -21,7 +22,8 @@ RESTRICT="test"
# From the gnome-python-extras eclass
RDEPEND=">=x11-libs/gtk+-2.4:2
>=dev-libs/glib-2.6:2
- $(python_gen_any_dep '>=dev-python/pygtk-2.10.3:2[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+ >=dev-python/pygtk-2.10.3:2[${PYTHON_USEDEP}]
!<=dev-python/gnome-python-extras-2.19.1-r2"
DEPEND="${RDEPEND}
virtual/pkgconfig
@@ -38,6 +40,7 @@ src_prepare() {
epatch "${FILESDIR}/${P}-python-libs.patch" #344231
sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
eautoreconf
+ python_setup
gnome2_src_prepare
}