summaryrefslogtreecommitdiff
path: root/dev-python/gnome-python-desktop-base
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/gnome-python-desktop-base
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/gnome-python-desktop-base')
-rw-r--r--dev-python/gnome-python-desktop-base/Manifest5
-rw-r--r--dev-python/gnome-python-desktop-base/gnome-python-desktop-base-2.32.0-r1.ebuild43
-rw-r--r--dev-python/gnome-python-desktop-base/metadata.xml8
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/gnome-python-desktop-base/Manifest b/dev-python/gnome-python-desktop-base/Manifest
new file mode 100644
index 000000000000..0d2c768bf264
--- /dev/null
+++ b/dev-python/gnome-python-desktop-base/Manifest
@@ -0,0 +1,5 @@
+DIST gnome-python-desktop-2.32.0.tar.bz2 621277 SHA256 09dbd580bf3b0ef60f91b090eafe6d08ddcc50a609e2b425a7f8eca46d4e0ee9 SHA512 51beefd21fa3aa6242ba4c66e57d940372fbf4a84ffe34063339f6e7e7c22e76d281b25d5f113de3780a0dbf733c7e07142f05a285056cda26736323b4185d18 WHIRLPOOL 5713353291a34e0a03152ad76c46391e3ab246efc17b63193fc0b26b02176eb78ce134c8d0cabcb3480bd2dbb3446b7b6b301cffbfac3ce915e21a974947e37e
+EBUILD gnome-python-desktop-base-2.32.0-r1.ebuild 1077 SHA256 d47a0e3b3b5c021af0beef308789c9c2fd79b9b327197e01788caa62059ff3a2 SHA512 3de5611926b91175e217c7e65f976f6445007726b1afb212f1b29ccb4f4c07f99f2d71af7354639e395c541f704ab0681ec62544811163a60546a3fcd8b5d4d7 WHIRLPOOL 7af7e77b250ec9121039f3b59c5cfd6762dc4f2c7b2aa612412cafbec33d1c020b3faa376799d862d7443ef92a7a86ae41cd62a733ea9d33e7b915695b55c5f6
+MISC ChangeLog 2491 SHA256 f4cb3e4e3e663c7b41653d9bebeed93a83eb4e658397bb940d7fb6ecc36227a4 SHA512 0202ea89c9f9293a3553bce938d926244ddd8fa0e137ee6c32b56efb02da139aa3215dfccbc3158d2ea50dae333e1d487bddc2d6fe9e4dcc3c4a320bf1df7688 WHIRLPOOL 11c8cd933251676fa91ca205d1c3c3c6633b377a2ceab263da09bea004bc22c8ffd3a1ba99f8cfb5a761f1ad56e40612d697d00a20dbca4d106343060cc5c9c4
+MISC ChangeLog-2015 8915 SHA256 be6892f75e02452b579b21f14e4f877cfc1405ee54fadc60500fdf28b2d241ec SHA512 27d284fc05800f8c5567f667c0d687ce467a8479d69a1c5458dd8c5b70bff2cfdc250ba85c716bfbf98554fd6791e07b6cee53e67e79010dd3e7a57e8706c343 WHIRLPOOL bfaaafe76dfcf75f21ab07e1b3363d3118ee7d754ca07bc2a7ba993c3741d516d6343fc9d966dc34f291d11aaa8abcfca057c648a68a377ca3ab89b27643a11e
+MISC metadata.xml 249 SHA256 4505b0bfeadff287958620b7dc7b7209699065a8f17139a237a5dd409a726a97 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506 WHIRLPOOL 333a938ee1d2124595596c572697bf5ebad523a92ba12005cfb12e6bb6270881a94a911f0cc9c1cf2bb571559e8271e07dfd307dabe50058236dbe7103562b92
diff --git a/dev-python/gnome-python-desktop-base/gnome-python-desktop-base-2.32.0-r1.ebuild b/dev-python/gnome-python-desktop-base/gnome-python-desktop-base-2.32.0-r1.ebuild
new file mode 100644
index 000000000000..18367683dba2
--- /dev/null
+++ b/dev-python/gnome-python-desktop-base/gnome-python-desktop-base-2.32.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python2_7 )
+GNOME_ORG_MODULE="gnome-python-desktop"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit gnome2 python-any-r1
+
+# This ebuild does nothing -- we just want to get the pkgconfig file installed
+
+DESCRIPTION="Provides python the base files for the Gnome Python Desktop bindings"
+HOMEPAGE="http://pygtk.org/"
+
+KEYWORDS="alpha amd64 arm ~hppa ia64 ppc ppc64 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+IUSE=""
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+# From the gnome-python-desktop eclass
+RDEPEND="$(python_gen_any_dep '>=dev-python/pygtk-2.10.3:2[${PYTHON_USEDEP}]')
+ >=dev-libs/glib-2.6.0:2
+ >=x11-libs/gtk+-2.4.0:2
+ !<dev-python/gnome-python-extras-2.13
+ !<dev-python/gnome-python-desktop-2.22.0-r10"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+RESTRICT="test"
+
+src_prepare() {
+ gnome2_src_prepare
+ python_fix_shebang .
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+ gnome2_src_configure \
+ --disable-allbindings
+}
diff --git a/dev-python/gnome-python-desktop-base/metadata.xml b/dev-python/gnome-python-desktop-base/metadata.xml
new file mode 100644
index 000000000000..39980802b1da
--- /dev/null
+++ b/dev-python/gnome-python-desktop-base/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+</pkgmetadata>