summaryrefslogtreecommitdiff
path: root/dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild')
-rw-r--r--dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild b/dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild
new file mode 100644
index 000000000000..540f323b3815
--- /dev/null
+++ b/dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python2_7 )
+
+inherit versionator eutils gnome2 python-any-r1
+
+# This ebuild does nothing -- we just want to get the pkgconfig file installed
+
+MY_PN="gnome-python"
+DESCRIPTION="Provides the base files for the gnome-python bindings"
+HOMEPAGE="http://pygtk.org/"
+PVP="$(get_version_component_range 1-2)"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP}/${MY_PN}-${PV}.tar.bz2"
+
+IUSE=""
+LICENSE="LGPL-2.1"
+SLOT="2"
+RESTRICT="${RESTRICT} test"
+
+# From the gnome-python eclass
+RDEPEND=">=x11-libs/gtk+-2.6:2
+ >=dev-libs/glib-2.6:2
+ $(python_gen_any_dep '
+ >=dev-python/pygtk-2.14.0:2[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.17:2[${PYTHON_USEDEP}]
+ ')
+ !<dev-python/gnome-python-2.22.1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-allbindings
+}