summaryrefslogtreecommitdiff
path: root/dev-python/gmpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/gmpy
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/gmpy')
-rw-r--r--dev-python/gmpy/Manifest1
-rw-r--r--dev-python/gmpy/gmpy-2.0.8.ebuild80
2 files changed, 0 insertions, 81 deletions
diff --git a/dev-python/gmpy/Manifest b/dev-python/gmpy/Manifest
index 5c9c39e42867..457dc69c263b 100644
--- a/dev-python/gmpy/Manifest
+++ b/dev-python/gmpy/Manifest
@@ -2,5 +2,4 @@ AUX gmpy-2.0.8-fix-mpir-types.patch 636 BLAKE2B 3f9a73390cab39ac02c9cdbf6c78381a
AUX gmpy-2.0.8-test-exit-status.patch 1482 BLAKE2B 5fce4170ce1993cf7e44077b81ecf45b4c8d3b779cb8744c6deef6444cc728a4cf7831aac0cc31a0b6315518bead442ce232e0052e72229f397691c21afb5890 SHA512 bbb708c0323167cf86c60ef6d398a588adc9a7ccc96eb1cee9d36c38b34c69c896a7df99f50611b29ba6ccb79f77408d274074bd4878e86b8f3bfc38675b74d6
DIST gmpy2-2.0.8.zip 280551 BLAKE2B b73c48b739ae6972231672ad28598c09e00db6348cd281d190c6dfcf49b0e977563baabe84825658d78bf1e2ac4927ad1882787b6d4efd19f28a4f7fd6a061b4 SHA512 090f449641f378c73eb166831b1d956c6cee3da83e42fde8741f18aa0fa687e37927fc3b045d4b35e3a3b75570e6b1074150d8bc29d16119ab5c717bcfcf9fb4
EBUILD gmpy-2.0.8-r1.ebuild 1525 BLAKE2B b11bae0fc5161131f3529d8665e837c3ad50c41fc34825fd72cca2d023caaaae54c68773be1c8b0614a6626305f3bec7759baa1280e2a5e4b01ca4a6ce54b467 SHA512 c01b159286f9e64a8ef1a7392d46db595a593b1516985ad8ec72545620b26c4c823732339737f3815b2418c3c15725b581d98321a4b852e146125fc7b3675c68
-EBUILD gmpy-2.0.8.ebuild 1823 BLAKE2B 64030784048bd5d114d91957a821b2e9b012a54fce77d4efa95b98e2fdb606f6f53e5bc378bdf9f5f615636751c9a53f924f64cc1c95b623bd63556cbfa4cf9a SHA512 746d40e010f7d890d36f2407ba64a890516c136060fb5e2e9b92621f165125468544441ef74e0168aeacd98a2248af9fce994eb1a9b1603cb188a2d60735883b
MISC metadata.xml 795 BLAKE2B df987c466b2666db915c405dea507c17f90181c2e2948885292a6de44ba0c4bec640fe25bea3b8b8105d035c3ff999750b747cfd7f4caaab561f459056823eb5 SHA512 e7f8324cdacceed22f28e27a224668f59955fb5a639d26376da037b0d21437ef57708c7c325e00c771df9e11050be8dc423a3d4b631599da2cc1ef3f97cf3795
diff --git a/dev-python/gmpy/gmpy-2.0.8.ebuild b/dev-python/gmpy/gmpy-2.0.8.ebuild
deleted file mode 100644
index 3b2f17023980..000000000000
--- a/dev-python/gmpy/gmpy-2.0.8.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
-
-inherit distutils-r1
-
-MY_PN="${PN}2"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Python bindings for GMP, MPC, MPFR and MPIR libraries"
-HOMEPAGE="https://github.com/aleaxit/gmpy"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.zip"
-S="${WORKDIR}"/${MY_P}
-
-LICENSE="LGPL-2.1"
-SLOT="2"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="doc mpir"
-
-RDEPEND="
- >=dev-libs/mpc-1.0.2:=
- >=dev-libs/mpfr-3.1.2:=
- !mpir? ( dev-libs/gmp:0= )
- mpir? ( sci-libs/mpir:= )"
-DEPEND="${RDEPEND}
- app-arch/unzip
- doc? ( $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]') )"
-
-PATCHES=(
- "${FILESDIR}"/${P}-fix-mpir-types.patch
- "${FILESDIR}"/gmpy-2.0.8-test-exit-status.patch
-)
-
-python_check_deps() {
- use doc || return 0
- has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
-}
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
-
- # rm non std test file
- rm test*/gmpy_test_thr.py || die
- # testing for contents of __dir__ is really silly, and fails
- sed -i -e '/__dir__/,+1d' test3/*.py || die
-}
-
-python_configure_all() {
- mydistutilsargs=(
- $(usex mpir --mpir --gmp)
- )
-}
-
-python_compile() {
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- cd test || die
- "${EPYTHON}" runtests.py || die "tests failed under ${EPYTHON}"
- if python_is_python3; then
- cd ../test3 || die
- else
- cd ../test2 || die
- fi
- "${EPYTHON}" gmpy_test.py || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}