summaryrefslogtreecommitdiff
path: root/dev-python/gmpy/gmpy-2.1.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-19 07:47:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-19 07:47:44 +0000
commitfcefa9aa213e0ff26901b351fccd47393113ae5d (patch)
tree16ff06e1d47c8dc06b954f726f24cd6f941e3596 /dev-python/gmpy/gmpy-2.1.5.ebuild
parent8bb75334c4b9f91e9f95784e986ed31b4bc11f92 (diff)
gentoo auto-resync : 19:12:2022 - 07:47:44
Diffstat (limited to 'dev-python/gmpy/gmpy-2.1.5.ebuild')
-rw-r--r--dev-python/gmpy/gmpy-2.1.5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/gmpy/gmpy-2.1.5.ebuild b/dev-python/gmpy/gmpy-2.1.5.ebuild
new file mode 100644
index 000000000000..708409ffeb6a
--- /dev/null
+++ b/dev-python/gmpy/gmpy-2.1.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_PN="${PN}2"
+MY_P="${MY_PN}-${PV/_beta/b}"
+
+DESCRIPTION="Python bindings for GMP, MPC, MPFR and MPIR libraries"
+HOMEPAGE="
+ https://github.com/aleaxit/gmpy/
+ https://pypi.org/project/gmpy2/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-3+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+DEPEND="
+ >=dev-libs/mpc-1.0.2:=
+ >=dev-libs/mpfr-3.1.2:=
+ dev-libs/gmp:0=
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ cd test || die
+ "${EPYTHON}" runtests.py || die "tests failed under ${EPYTHON}"
+}