summaryrefslogtreecommitdiff
path: root/dev-python/glymur/glymur-0.8.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/glymur/glymur-0.8.10.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/glymur/glymur-0.8.10.ebuild')
-rw-r--r--dev-python/glymur/glymur-0.8.10.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/glymur/glymur-0.8.10.ebuild b/dev-python/glymur/glymur-0.8.10.ebuild
deleted file mode 100644
index 0a19aa6c6587..000000000000
--- a/dev-python/glymur/glymur-0.8.10.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-MYPN=Glymur
-MYP=${MYPN}-${PV}
-
-DESCRIPTION="Python tools for accessing JPEG2000 files"
-HOMEPAGE="https://github.com/quintusdias/glymur"
-SRC_URI="mirror://pypi/${MYPN:0:1}/${MYPN}/${MYP}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-
-RDEPEND="
- dev-python/contextlib2[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- media-libs/openjpeg:2=
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- dev-python/numpydoc[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${MYP}"
-
-python_compile_all() {
- if use doc; then
- emake -C docs html
- HTML_DOCS=( docs/build/html/. )
- fi
-}
-
-python_test() {
- "${EPYTHON}" -m unittest discover || die
-}