summaryrefslogtreecommitdiff
path: root/dev-python/glance_store
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/glance_store
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/glance_store')
-rw-r--r--dev-python/glance_store/Manifest5
-rw-r--r--dev-python/glance_store/glance_store-0.22.0.ebuild47
-rw-r--r--dev-python/glance_store/glance_store-0.23.0.ebuild53
-rw-r--r--dev-python/glance_store/metadata.xml25
4 files changed, 130 insertions, 0 deletions
diff --git a/dev-python/glance_store/Manifest b/dev-python/glance_store/Manifest
new file mode 100644
index 000000000000..2f0cec0f3217
--- /dev/null
+++ b/dev-python/glance_store/Manifest
@@ -0,0 +1,5 @@
+DIST glance_store-0.22.0.tar.gz 130377 BLAKE2B 7dc46dde1dbccddbbabf0e0d1d4033429e4ffa3d6dec6fe379b6f7aabcaa5eeed639aa2c76e5b85ccf3444f4e76ec894251bdb8ae573b094e657fe61acb7887b SHA512 3de073fd4926513674b87afb15a2d4485c4a98f76c7d36cd0957a9cd848399bfb1fc6b3b40550522b712e9bbddf8efec5c3fc629a944fe447543d35eb7184168
+DIST glance_store-0.23.0.tar.gz 140917 BLAKE2B 764510b2d24b633a9120d4c39e66100a75de23c0bd7ef633bff4d381369c67d6a21b4f16019432ac02c6ed1b995c5c6373014dd9a5bd4df4981721146ced4145 SHA512 ee3d1187ac47427981af294604bd4742a12b60bdf406039a86c5eb33645e1407bc077ae079ea07b9c031922d9350b0e2eb7eaba70f51854c288faf90f9cd7b41
+EBUILD glance_store-0.22.0.ebuild 1631 BLAKE2B 1c3c27e87efeb8314db12b798992fc40ea09a452ab1c58cb2631fbcac065ceb12938ba31791299f2aeb2e936046d8427db3fabc946faccf6a6edb2c77adb4cc6 SHA512 09fdad30dd0da08e1e685bf85a3dd6f5c95379d36743d6bc30cf67bdd8ee82e42a7ebf00bbcaf791942fb2a7376279c9c0a2713395e744f650d5a601fa1f0ed3
+EBUILD glance_store-0.23.0.ebuild 1812 BLAKE2B c911ba5e9826608d7280dabd3471f8da1c4877b7656152f97017960eadc42b27ca727631d649e851e5ca65246b01a17298db7369ff09896dc7443d76d0abb0e0 SHA512 b38b51ef900b83b056bc80147bd436c8d383ee7634f750b415759ca275a728e8755b50a7809b593e21d89f03ece84e327408498746210cb59ea2b4548e0ab073
+MISC metadata.xml 807 BLAKE2B c5195ef9669d04dc0f81f47b07e802984114b15bf4dedaf99b7214187befb556765a4b14c7d55c9bbbf1dcc2acb4f22e7c5a12a65912cb9f2bbcb73d1cafa4a5 SHA512 3479866f525828fbd21f7d0953088720d0045bf2e00d8dd4cb5bba25f7d5ba939c4bc9bac89d1f9bbf5c3a815f0d5199045f6ad0585c6712843dc1f26135705d
diff --git a/dev-python/glance_store/glance_store-0.22.0.ebuild b/dev-python/glance_store/glance_store-0.22.0.ebuild
new file mode 100644
index 000000000000..f39ec966e1f5
--- /dev/null
+++ b/dev-python/glance_store/glance_store-0.22.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for glance"
+HOMEPAGE="https://github.com/openstack/glance_store"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/oslo-config-4.0.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-config-4.3.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-config-4.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-i18n-3.15.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-1.19.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.20.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ virtual/python-enum34[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+ <dev-python/eventlet-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/jsonschema-2.5.0[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.1.0[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/glance_store/glance_store-0.23.0.ebuild b/dev-python/glance_store/glance_store-0.23.0.ebuild
new file mode 100644
index 000000000000..6ce6694edf7d
--- /dev/null
+++ b/dev-python/glance_store/glance_store-0.23.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for glance"
+HOMEPAGE="https://github.com/openstack/glance_store"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="cinder swift vmware"
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-1.19.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.25.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ virtual/python-enum34[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ <dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.6.0[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ cinder? (
+ >=dev-python/python-cinderclient-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/os-brick-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-rootwrap-5.8.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-privsep-1.23.0[${PYTHON_USEDEP}]
+ )
+ swift? (
+ >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/python-swiftclient-3.2.0[${PYTHON_USEDEP}]
+ )
+ vmware? ( >=dev-python/oslo-vmware-2.17.0[${PYTHON_USEDEP}] )
+"
diff --git a/dev-python/glance_store/metadata.xml b/dev-python/glance_store/metadata.xml
new file mode 100644
index 000000000000..7907f3a2f3fc
--- /dev/null
+++ b/dev-python/glance_store/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>openstack@gentoo.org</email>
+ <name>Openstack</name>
+ </maintainer>
+ <longdescription lang="en">
+ Glance's stores library
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">glance_store</remote-id>
+ <remote-id type="launchpad">oslo</remote-id>
+ <remote-id type="github">openstack/glance_store</remote-id>
+ </upstream>
+ <use>
+ <flag name="cinder">enable cinder backend supprt</flag>
+ <flag name="swift">enable swift backend supprt</flag>
+ <flag name="vmware">enable vmware backend supprt</flag>
+ </use>
+</pkgmetadata>