summaryrefslogtreecommitdiff
path: root/dev-python/git-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /dev-python/git-python
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'dev-python/git-python')
-rw-r--r--dev-python/git-python/Manifest2
-rw-r--r--dev-python/git-python/git-python-2.1.11.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/git-python/Manifest b/dev-python/git-python/Manifest
index e24979e5e62a..bc00e1413c9e 100644
--- a/dev-python/git-python/Manifest
+++ b/dev-python/git-python/Manifest
@@ -1,5 +1,7 @@
DIST GitPython-1.0.2.tar.gz 387615 BLAKE2B 50915f5ea98a47eeaf086f57ecc0847592721390b7eb38bc3d03e8258c74b4708cb3043142c160139d399337180300037db874d126abb5e54bbae855cd4e8039 SHA512 faff50d5272158f1d05d932e7827c05272f9a28772aabbcabd631b735bb4d8306d2861d13c327d02a4c554bd9a9902c473fb282318036405497dd8bf0fcc51a8
+DIST GitPython-2.1.11.tar.gz 428531 BLAKE2B 18b00f1e622c6588c14e1625f944d117348fb77e67161117510f42c8381db8cde8c6e16fa911edabfc4410239622fb845931b247bab4133585d2ec27969fea4c SHA512 5f964ee56c3f27c28f502150216af29b8463b19d9c0f773458dbabf17ba8587ee5c5e3fbcb31ad46c55e202d06bae447fd40007890a1bc116fe0370cdfc6401f
DIST GitPython-2.1.7.tar.gz 426362 BLAKE2B 1d543b760bc0dbfdf95b120876c1f3454442a2e2bca69529229316fe5345129b852f4f6195066bc4750ac650083750c5ae0f842aeae871cba969aaf4c6563899 SHA512 3081fcf4944d49042fa95b55f1f0a152b405830fa592fbe546710798388e2bd7422bd2c62f5a7545f0820693fe1948ef31e1485d7b6bc2b37f2b807962e7da83
EBUILD git-python-1.0.2.ebuild 1073 BLAKE2B 6e0dd038d4c0f28cb7edbf89a8f1f7a3cc5425adc7385e16b4ce181d125eb4897e51d4837df9c7561c0f71dac15c9e2de0a4c31f69eaa91c89be87d17b564b91 SHA512 a6c1b36aa1846f904cc4f9a9d1d9efd4af92f8d8699db38dfb91b576b944c10f8809e292507188b64a3bd50d9f5f27a2483464dd13942e0763a4d13e72d17fec
+EBUILD git-python-2.1.11.ebuild 891 BLAKE2B 3052bd8613842f2fbcb22ddd83992f096aa54d627d4a0d71e97779c355e967b52b4143d5f973f228359f91fc524e6fd6261c8ade182daba2ebfd6b722f5e0404 SHA512 faa49d40a5fcc9be3c814716b2227dc3f419d0ab5faa5b5c550d2f9bfa42f871e7ba17736bfe3b10c0b7728b5316b02ade56addbde89ba4d2286f7173c9b0bc3
EBUILD git-python-2.1.7.ebuild 892 BLAKE2B 1dbe094db47261a1a8e6c841d4e7be6be55944a709c337ff6564b30f22b991987de2cbd813b3f9cfa5ce49a2bfe0e479be9c7f9e5af4ffc01fbccf45bd54a56c SHA512 e6d094f2729cbf83b1d03818ec2c059d760f6e2ee6e81462f90b8570b07069e7cfe539f35db2f5e92ba0790579e96227eda06133bc69431382863dd133d0d64f
MISC metadata.xml 382 BLAKE2B 9853412552202bb0134ea88f7eae6b36c5c17920cd2834bec4a487cd6e1e6a5421db13a5b5ca7de1bc366ca057c17e2d89f3ea0973023de76a0a0783065d6dc6 SHA512 3f31be6d8a7fc5622f56141778f1779ff092a7e50f6ee162edc7854eb84b896206382edacf678e3f53f513727ca67e3cce0b6b6f50be7cbc93533201533ebe85
diff --git a/dev-python/git-python/git-python-2.1.11.ebuild b/dev-python/git-python/git-python-2.1.11.ebuild
new file mode 100644
index 000000000000..96f8566ba217
--- /dev/null
+++ b/dev-python/git-python/git-python-2.1.11.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+MY_PN="GitPython"
+MY_PV="${PV/_rc/.RC}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Library used to interact with Git repositories"
+HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.org/project/GitPython/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+# Tests only work with the GitPython repo
+RESTRICT="test"
+
+RDEPEND="
+ dev-vcs/git
+ >=dev-python/gitdb2-2.0.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"