summaryrefslogtreecommitdiff
path: root/dev-python/ginga
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/ginga
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/ginga')
-rw-r--r--dev-python/ginga/Manifest4
-rw-r--r--dev-python/ginga/files/ginga-no-roboto.patch19
-rw-r--r--dev-python/ginga/ginga-2.6.5.ebuild75
-rw-r--r--dev-python/ginga/metadata.xml20
4 files changed, 118 insertions, 0 deletions
diff --git a/dev-python/ginga/Manifest b/dev-python/ginga/Manifest
new file mode 100644
index 000000000000..0b1ecf7ee280
--- /dev/null
+++ b/dev-python/ginga/Manifest
@@ -0,0 +1,4 @@
+AUX ginga-no-roboto.patch 597 BLAKE2B f3e688971c9d3920be0813a3815f36a8c766194b8116d1fe1f1a4aa986d5f5ee69aac13edcb961638d65d4f7bcd2e906ddff3402e95fbaa41dd6473a52b18f60 SHA512 e4e03b31ef61b3c71f5a049d23e721634d5c54646abf35d13df05423f2f215ff50aa7c867077bdb0216e2e8482e5a2bd75d24c505fcb09cb4ce96ac21d327c0d
+DIST ginga-2.6.5.tar.gz 19969984 BLAKE2B a28dcd6216274eb442fab74c28a5d2acd37cdf3fabe5aa470533c3bfd3b4b43227efff9fee98f03691acd1449f8344094f24bd6a13628c0fa5b8a18e27dbf78a SHA512 66c55662a8ce1fe683cdf6a83511f39146fadf10d1fedabd6d6c5c46662a3abd2496bd1f0200612a84bdad246f960990e242bccee7a8a13e3aaf88a4884ceb80
+EBUILD ginga-2.6.5.ebuild 1989 BLAKE2B f271965692f4acf712eff58eb3212d29c26fbec35d8d66c75daab2d4485cd82a0cbcdf5182f5463fb063076391dbfd2ba5fbadf2a7bd630294d3db89b96053bd SHA512 6190fe210a7f5a31067f92ea877a09f65a9261a58fdc97480766a1e395ca57782922d04ff1bc0df12a81bf6046239877ce30bc2ad028430dc37bd130310e53bc
+MISC metadata.xml 849 BLAKE2B fc93ade01d6eef46d4e72f2031d96523fdf12bec759525fa7e750d60d4eb6e619253678c58821dbad6510a18f68827dfd19e8b3334f7c5e0c1e5aba283575f17 SHA512 50343b22bb87eb298d17182553ddbbec417198e65f6c86177760e3fdc1c117f2e40dce6b539831d6dc85f820efa13b0b4e739dc40222c7ad2f318c81b78a2d33
diff --git a/dev-python/ginga/files/ginga-no-roboto.patch b/dev-python/ginga/files/ginga-no-roboto.patch
new file mode 100644
index 000000000000..36b222fea5e2
--- /dev/null
+++ b/dev-python/ginga/files/ginga-no-roboto.patch
@@ -0,0 +1,19 @@
+From: Ole Streicher <olebole@debian.org>
+Date: Tue, 2 Aug 2016 09:06:36 +0200
+Subject: Don't install the fonts included in the package.
+
+Use the package roboto-fonts-unhinted instead.
+---
+ ginga/fonts/setup_package.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ginga/fonts/setup_package.py b/ginga/fonts/setup_package.py
+index 9dd1e93..fe0ed0a 100644
+--- a/ginga/fonts/setup_package.py
++++ b/ginga/fonts/setup_package.py
+@@ -3,4 +3,4 @@ from __future__ import absolute_import
+
+
+ def get_package_data():
+- return {'ginga.fonts': ['*/*.ttf', '*/*.txt']}
++ return {}
diff --git a/dev-python/ginga/ginga-2.6.5.ebuild b/dev-python/ginga/ginga-2.6.5.ebuild
new file mode 100644
index 000000000000..296a6bb9c94e
--- /dev/null
+++ b/dev-python/ginga/ginga-2.6.5.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_REQ_USE='tk?'
+
+inherit distutils-r1 eutils xdg-utils virtualx
+
+DESCRIPTION="Astronomical image toolkit for Python"
+HOMEPAGE="https://ejeschke.github.io/ginga"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="examples gtk qt5 test tk"
+
+RDEPEND="
+ dev-python/astropy[${PYTHON_USEDEP}]
+ media-fonts/roboto
+ gtk? ( dev-python/pygobject[${PYTHON_USEDEP},cairo] )
+ qt5? (
+ dev-python/PyQt5[${PYTHON_USEDEP},help,gui,widgets]
+ dev-python/QtPy[${PYTHON_USEDEP},gui]
+ )
+"
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/QtPy[${PYTHON_USEDEP},gui] )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-no-roboto.patch )
+
+python_prepare_all() {
+ # use system astropy-helpers instead of bundled one
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ virtx esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ rm -r "${ED%/}"/usr/lib*/*/*/ginga/examples || die
+ if use examples; then
+ dodoc -r ginga/examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ domenu ginga.desktop
+}
+
+pkg_postinst() {
+ optfeature "Pick, Cuts, Histogram, LineProfile" \
+ dev-python/matplotlib sci-libs/scipy
+ optfeature "Online help browser" dev-qt/qtwebkit
+ optfeature "To save a movie" media-video/mplayer
+ optfeature "Speeds up rotation and some transformations" \
+ dev-python/numexpr dev-python/opencv dev-python/pyopencl
+ optfeature "Aids in identifying files when opening them" \
+ dev-python/filemagic
+ optfeature "Useful for various RGB file manipulations" dev-python/pillow
+
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
diff --git a/dev-python/ginga/metadata.xml b/dev-python/ginga/metadata.xml
new file mode 100644
index 000000000000..9b4ee82bcef3
--- /dev/null
+++ b/dev-python/ginga/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Ginga is a toolkit designed for building viewers for scientific image
+ data in Python, visualizing 2D pixel data in numpy arrays.
+ It can view astronomical data such as contained in files based on the
+ FITS (Flexible Image Transport System) file format. It is written and
+ is maintained by software engineers at the Subaru Telescope, National
+ Astronomical Observatory of Japan.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">ginga</remote-id>
+ <remote-id type="github">ejeschke/ginga</remote-id>
+ </upstream>
+</pkgmetadata>