summaryrefslogtreecommitdiff
path: root/dev-python/ghp-import
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/ghp-import
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/ghp-import')
-rw-r--r--dev-python/ghp-import/Manifest3
-rw-r--r--dev-python/ghp-import/ghp-import-0.4.1-r1.ebuild32
-rw-r--r--dev-python/ghp-import/metadata.xml8
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/ghp-import/Manifest b/dev-python/ghp-import/Manifest
new file mode 100644
index 000000000000..a28504213ed0
--- /dev/null
+++ b/dev-python/ghp-import/Manifest
@@ -0,0 +1,3 @@
+DIST ghp-import-0.4.1.tar.gz 5002 BLAKE2B 667a40c0d852799e97d295df76d17d50017880afc9b2daa27d49444da84c791af619dea06b282e15c4d627a9584a23c2aa9fafcf45d9e0e924f9a6a966d071b6 SHA512 8b0e6578f05dc74449082a840ccd609a43fba3ca1c4dffacaddc4b27d2e9e3eac565a5c9672734e6ec5f2e8872b13ae0bb8a5d6bae4ee6c4cf41ef7d2c0b2eda
+EBUILD ghp-import-0.4.1-r1.ebuild 712 BLAKE2B addf166a0b4650009a4466faa1f0bb993f3a7f3c15dfafd95b60c9a6234b91baf162981dc43892f105a8d3a240428853feae0c2b90e28258af6aa7bb8afb4ddc SHA512 a3bda407d8af4181740fef1268232b4044c6d29565126bdc77505a6294faff5ba8f1e3d545f379d731e421b3aa3cf0d0ccce2df8f148007fbc7ea3b9dbbcc769
+MISC metadata.xml 269 BLAKE2B c267b42e0527b3ab1992f4fd3e9b039cd25f184a3f344da4fb977770f44fefc0b9d0aa9f9ce1242496c53c67e39d897f0da4f63ceb94bcc8982bac47cdb2864b SHA512 c2c532992c1bbfc4679cca8ba3e1f920a1e45a82df940423284e344f560a4a978efd13feb7c8ffe7285f2ec0d8cdb1939783df2036350d09cce2abb3863be91e
diff --git a/dev-python/ghp-import/ghp-import-0.4.1-r1.ebuild b/dev-python/ghp-import/ghp-import-0.4.1-r1.ebuild
new file mode 100644
index 000000000000..7bad1544380d
--- /dev/null
+++ b/dev-python/ghp-import/ghp-import-0.4.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Copy your docs directly to the gh-pages branch"
+HOMEPAGE="https://github.com/davisp/ghp-import"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="tumbolia"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_prepare_all() {
+ ebegin 'patching setup.py'
+ sed \
+ -e '4ifrom codecs import open\n' \
+ -e '/LONG_DESC/s/))/), encoding = "utf-8")/' \
+ -i setup.py
+ STATUS=${?}
+ eend ${STATUS}
+ [[ ${STATUS} -gt 0 ]] && die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/ghp-import/metadata.xml b/dev-python/ghp-import/metadata.xml
new file mode 100644
index 000000000000..aaefa1f9da5d
--- /dev/null
+++ b/dev-python/ghp-import/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">ghp-import</remote-id>
+ <remote-id type="github">davisp/ghp-import</remote-id>
+ </upstream>
+</pkgmetadata>