summaryrefslogtreecommitdiff
path: root/dev-python/gherkin-official
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-16 03:02:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-16 03:02:52 +0000
commitb0735771a80a647a2ea5a03a87d5873d175bd744 (patch)
treeaed120d0dfeab57cb7f38b7a5d186b1c53ae10cd /dev-python/gherkin-official
parent57d1fe5ae0c56e604db5d29bf7b62d685c42e043 (diff)
gentoo auto-resync : 16:11:2024 - 03:02:52
Diffstat (limited to 'dev-python/gherkin-official')
-rw-r--r--dev-python/gherkin-official/Manifest4
-rw-r--r--dev-python/gherkin-official/gherkin-official-30.0.4.ebuild (renamed from dev-python/gherkin-official/gherkin-official-30.0.3.ebuild)13
2 files changed, 6 insertions, 11 deletions
diff --git a/dev-python/gherkin-official/Manifest b/dev-python/gherkin-official/Manifest
index c29c280ba378..cf81158a8c62 100644
--- a/dev-python/gherkin-official/Manifest
+++ b/dev-python/gherkin-official/Manifest
@@ -1,3 +1,3 @@
-DIST gherkin-30.0.3.gh.tar.gz 3858361 BLAKE2B 9955a2d48dfdbfda942c60d18108fa9abc7bc7e748f5296afb802fb05b5a3b4904b74d3cff364a0fad0b9b3d378799764c2620ccb0a84af689bc8d95c7d4fbc8 SHA512 c9d722982fe926eec57cc185043983cd2380bf6ce58e5743b53cb2b98127d3b3f8b6689c39c51c2d3697e5f40bc6f98beb4c239d601b1d7685e09f5dcaa07e00
-EBUILD gherkin-official-30.0.3.ebuild 758 BLAKE2B cdf24682fc4655771145d3c3cbb1f0c8c5675e1250e82b0c766b20c7df43541b2df48b6ba680294d076c80094c474b51980d497138ca230f2f2c4cbd90fb63ea SHA512 f4d86ede04e702fdaa78eb76871ff94ada89f4c7010f49d19ed228de7c4e192a6efa6dcaccd6d62e7fa5e88781818669d7da0f42b17a2c32945ed2193def825b
+DIST gherkin-30.0.4.gh.tar.gz 3858403 BLAKE2B bdf5cf80f1e06c9e8464d3fbc5a56a594b75f3d8ae6ff13dafcd583aa6571e1a6ba4aa4dd344f7c532174b09829bdaf9aae1e1e02339521e2836dbf9b3014108 SHA512 52cd5bab779e46d5d2c451558b545fb8ac408d1d5d11558e1dace94d77472ca271589eb183c412093fcbdef2574a495fdd11c98ce97d8146077a54b3369a9a6e
+EBUILD gherkin-official-30.0.4.ebuild 729 BLAKE2B a2d4300e90751b688074521825c976dcccf683d933da8d0651bfbfefea48e843616be311c54e633dad2e1e5faa2af66a210f2bd2e01ed18f438e15ea4cfa4146 SHA512 2b24ca1855a4d395d9a2bb2968af02e05dbb73e8fcbc8089e3f17dd8d26ab831b92f5b88c74b0f92855a3affebbe9d1bfd5bfc220e49f29a9bfaa97234c34aad
MISC metadata.xml 405 BLAKE2B caf402cb5e5431bfb88d8250e3ba9422505d35118775b5890168e09c5c68c8028179c5f33e87273d674ff7045a693287ed2bebcf80a3630c1b0cd76af1d5739c SHA512 cc7afa9928d998af2d4b6226fbd196d18496ff349a578466a143d2a9917171399e40ff5791daab2d74276fb7ed0d5362c0d5a806b3a31df547b280c0f2d11cb8
diff --git a/dev-python/gherkin-official/gherkin-official-30.0.3.ebuild b/dev-python/gherkin-official/gherkin-official-30.0.4.ebuild
index 4a0f1cca107a..6b0586eb35a8 100644
--- a/dev-python/gherkin-official/gherkin-official-30.0.3.ebuild
+++ b/dev-python/gherkin-official/gherkin-official-30.0.4.ebuild
@@ -3,6 +3,9 @@
EAPI=8
+# note: only bump when there is a release on pypi, GH tags (which include
+# tests) are for the whole package and may have no changes to python/
+
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
@@ -17,18 +20,10 @@ S=${WORKDIR}/gherkin-${PV}/python
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~arm64 ~x86"
RDEPEND="
dev-python/typing-extensions[${PYTHON_USEDEP}]
"
distutils_enable_tests pytest
-
-python_install() {
- distutils-r1_python_install
-
- # dev-python/pytest-bdd tests currently fail without this
- python_moduleinto gherkin
- python_domodule ../gherkin-languages.json
-}