summaryrefslogtreecommitdiff
path: root/dev-python/gherkin-official
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-30 22:43:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-30 22:43:19 +0000
commit4856d9d89d9f533d36c415521ddc9c23be3c6033 (patch)
treed8136d92c14ec4c657b05bceeebde6cff901ed94 /dev-python/gherkin-official
parentfa19575643c607e28b1572821c413ad7cb8eea09 (diff)
gentoo auto-resync : 30:01:2025 - 22:43:19
Diffstat (limited to 'dev-python/gherkin-official')
-rw-r--r--dev-python/gherkin-official/Manifest2
-rw-r--r--dev-python/gherkin-official/gherkin-official-31.0.0.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/gherkin-official/Manifest b/dev-python/gherkin-official/Manifest
index 6d20cd2ca2f1..5ce3750c79e0 100644
--- a/dev-python/gherkin-official/Manifest
+++ b/dev-python/gherkin-official/Manifest
@@ -1,3 +1,5 @@
DIST gherkin-30.0.4.gh.tar.gz 3858403 BLAKE2B bdf5cf80f1e06c9e8464d3fbc5a56a594b75f3d8ae6ff13dafcd583aa6571e1a6ba4aa4dd344f7c532174b09829bdaf9aae1e1e02339521e2836dbf9b3014108 SHA512 52cd5bab779e46d5d2c451558b545fb8ac408d1d5d11558e1dace94d77472ca271589eb183c412093fcbdef2574a495fdd11c98ce97d8146077a54b3369a9a6e
+DIST gherkin-31.0.0.gh.tar.gz 3850999 BLAKE2B e38bdd97af5d3a011e2c31e2cc67f25c72a4e729c9af8be4355a4a9155d83b403781f182f05e8db9b10cb929bbd208067ef39433982514bee29afa2aa4d621b4 SHA512 7b512a5ef2d4e840939f6109ff850913052dbb7263d8013a79f3485cc4037a3a2967706e9d8fbb9e7e436863819c89214953f493fa4666a496465fdb20d7c524
EBUILD gherkin-official-30.0.4.ebuild 727 BLAKE2B f5dffb87179a179c790a6b07282a3e531d71b8902784e1a99395086dbfcc3e9f0adc38e9dd78d8bed25c8ff42b9c0afa3fa2fde78c4039c16a7008c641d95801 SHA512 f57e5538995a0f16897dca1d0c2cedb60d4926342eb7c87d326bf5832f6703e8b2b788fbb06855223e69accc38cd0806f17c6e92c92d31d9ad8230c9d74617b6
+EBUILD gherkin-official-31.0.0.ebuild 734 BLAKE2B 42fccdc44b3f9573f8cd1e551213c7057b36c530952a05b2c33dc93e4a01adbdb2e4f3dc685383233800f49fcb2d40a92b7f39499a8f0778dbb2b4928d8d8020 SHA512 3628a503969dffbf46c5cb267923f031ab2274ce7b2704adfd9233b0f0d17a33f9727620ecb9398a613a32ac356a18c76dfd83e4952f8cfb618d0d34e7f21579
MISC metadata.xml 405 BLAKE2B caf402cb5e5431bfb88d8250e3ba9422505d35118775b5890168e09c5c68c8028179c5f33e87273d674ff7045a693287ed2bebcf80a3630c1b0cd76af1d5739c SHA512 cc7afa9928d998af2d4b6226fbd196d18496ff349a578466a143d2a9917171399e40ff5791daab2d74276fb7ed0d5362c0d5a806b3a31df547b280c0f2d11cb8
diff --git a/dev-python/gherkin-official/gherkin-official-31.0.0.ebuild b/dev-python/gherkin-official/gherkin-official-31.0.0.ebuild
new file mode 100644
index 000000000000..8e18424acfc2
--- /dev/null
+++ b/dev-python/gherkin-official/gherkin-official-31.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2024-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# note: only bump when there is a release on pypi, GH tags (which include
+# tests) are for the whole package and may have no changes to python/
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1
+
+DESCRIPTION="Gherkin parser/compiler for Python"
+HOMEPAGE="https://github.com/cucumber/gherkin/"
+SRC_URI="
+ https://github.com/cucumber/gherkin/archive/refs/tags/v${PV}.tar.gz
+ -> gherkin-${PV}.gh.tar.gz
+"
+S=${WORKDIR}/gherkin-${PV}/python
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest