summaryrefslogtreecommitdiff
path: root/dev-python/gfloat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-12 00:08:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-12 00:08:13 +0100
commitf0ddcad13515f66d2f3bf827d33c277bdba7e1dd (patch)
tree3e1da8fa4626163bda62e9e8b6129867de5be46d /dev-python/gfloat
parent65ff3cc3bd9c3f8e718a67dfecf1f8215bf5d1d4 (diff)
gentoo auto-resync : 12:06:2024 - 00:08:13
Diffstat (limited to 'dev-python/gfloat')
-rw-r--r--dev-python/gfloat/Manifest2
-rw-r--r--dev-python/gfloat/gfloat-0.3.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/gfloat/Manifest b/dev-python/gfloat/Manifest
index 735c3dcd7cf7..2c70395d6a8b 100644
--- a/dev-python/gfloat/Manifest
+++ b/dev-python/gfloat/Manifest
@@ -1,3 +1,5 @@
DIST gfloat-0.2.1.tar.gz 40460 BLAKE2B 9103140b2523c1e0f430bdf066c1625c71783d30d3d6754cd44c626ce6ca4204742188d967489ff2dba65df6ac51989551c14ee6ae66302c452c765d5a0eca20 SHA512 50bb770795b8284c9071f345667772ecd334a7c44368acf173dd65094f9fe9ac473ae0cc250f35dfafdb19d5fe039ad3258c4256fbc281feac41f192ed139cc5
+DIST gfloat-0.3.tar.gz 43790 BLAKE2B 3b6628dd6410090a684bc253965e167297f4105e3690b9ac38c0192c202fbc7e02026103723721494d4826d835b70a217114335201ab1c329d6bac02412f9e7f SHA512 2df65a3a188e99d1aa3da1b067aa3eaa9aabc22f42414b773c312d9c8dae9baf34d797f947a1646ea89e1db8f2bdb5f97a9672c292e2e0a2a8312e0e6f2fc496
EBUILD gfloat-0.2.1.ebuild 636 BLAKE2B 004694360cbab3810040ba9e8a679a5bf963484af9f0a53d104faf0c9ac28d3f1ac03ab0338bbf09078986cf4b1c29a348a5f9c26414da715324d132c7485807 SHA512 e21d9cae7e565e10a33216b0bb61d2d3b810a2c428326d8bca52b802e47270ae2e16aa258b72155093baf1f2acb76598caa13930096b0e3cc001d57c1048c147
+EBUILD gfloat-0.3.ebuild 636 BLAKE2B 004694360cbab3810040ba9e8a679a5bf963484af9f0a53d104faf0c9ac28d3f1ac03ab0338bbf09078986cf4b1c29a348a5f9c26414da715324d132c7485807 SHA512 e21d9cae7e565e10a33216b0bb61d2d3b810a2c428326d8bca52b802e47270ae2e16aa258b72155093baf1f2acb76598caa13930096b0e3cc001d57c1048c147
MISC metadata.xml 353 BLAKE2B 7d99f8b4d1b169146dab1605d391c9db63777d6a07af8308d0df982ff0848fc8f27dd2186f4c0f33f1fb73b1e091c8cee007e2d5157afe4cc863b1178b6034f8 SHA512 e17c967db7e216a060f9b2d16e6e395bfca5074a32386f738e7484afad08fd06794ac0015dec856053c2d8ec3ae17e6e1751b393e788a770f778589abdf2d78a
diff --git a/dev-python/gfloat/gfloat-0.3.ebuild b/dev-python/gfloat/gfloat-0.3.ebuild
new file mode 100644
index 000000000000..3b16a101cbc9
--- /dev/null
+++ b/dev-python/gfloat/gfloat-0.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Generic floating-point types in Python"
+HOMEPAGE="
+ https://github.com/graphcore-research/gfloat/
+ https://pypi.org/project/gfloat/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ml-dtypes[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # requires mx (possibly git version), torch
+ test/test_microxcaling.py
+)