summaryrefslogtreecommitdiff
path: root/dev-python/geventhttpclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /dev-python/geventhttpclient
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'dev-python/geventhttpclient')
-rw-r--r--dev-python/geventhttpclient/Manifest2
-rw-r--r--dev-python/geventhttpclient/geventhttpclient-1.5.2.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/geventhttpclient/Manifest b/dev-python/geventhttpclient/Manifest
index 94d12040fc40..77fc91875331 100644
--- a/dev-python/geventhttpclient/Manifest
+++ b/dev-python/geventhttpclient/Manifest
@@ -1,5 +1,7 @@
DIST geventhttpclient-1.4.5.tar.gz 58183 BLAKE2B 48d44048e7040552824ed19ac49c6dda41536ffded56bae0d942c06f111a327a1d571872f35f388853b479ea1aaa6de518f86e7ee72e362360492530ade65131 SHA512 9ffe00c79b145dab104e1dce336e072060f315d9bee880daf64b5f1f52e661d810dab9a60286320a7d30cf0e794465f201c039cc31fe7ec325cdb3a8350c9f7d
DIST geventhttpclient-1.5.1.tar.gz 58398 BLAKE2B 9995e14c635b06f729d342b19187d4c4b935f903038950fc05e8d9260a341d3a551750c1cd46798ac2d97603d1dba449d4db3a51a44e49a1720ec23b1526edf8 SHA512 46fa5333149b86f5c4b5d06adfe5d49402d0220266c27507da1645f1da8a50562e142e37435a029bb4184c417e8a4123301a7dfc8769ce419e841afebc11247c
+DIST geventhttpclient-1.5.2.tar.gz 58467 BLAKE2B ea9476038685458cade41150c33226b4355018b8a8c22623e96186ff922d7f6b9518ca4108afff3bcfd18167bf288ef7f6366528050e300d720ef0e7b15ef649 SHA512 1edf153f88b9a7a954f9acc316ac76f06f2599bd3cf11b4a8f1df7b500e884f304601aae6a1dca8cedf24d4f78793176814eadc8b2c60fa90769df649723146e
EBUILD geventhttpclient-1.4.5.ebuild 1477 BLAKE2B 35bfeb29334f743c0bd7ee2ed476f51c056606f14caeaa149ea4d0cae6e66a5868b804528fc60cc542b07474b5598f30e6b007985255e1bc9b2798ab0497cb91 SHA512 68b9ef7dd73a8aa1da5fff02fec0edbce304bd0d3c26dc1be96f06ec3cce39f16a98e636673034d78cbead3a578c7a81fe1350876908bfdf0c23543147813fcf
EBUILD geventhttpclient-1.5.1.ebuild 1494 BLAKE2B b752e0854872fd9ecf130d8f3ea2d5edc70c9a479363142d3a6901b12ce422339bcf75a69b05e79b599a7b4d7812cc82b0d1a04647c246b2a0f4cbffaa7e5143 SHA512 b1e4a2641a731977a9116cb550df29bc329e72b528e6d7c6b809f95e5de249a985544d2eb58d18291ff46b99b7c35ffc4dc70081306dc69a1b907ac5ced8100b
+EBUILD geventhttpclient-1.5.2.ebuild 1494 BLAKE2B b752e0854872fd9ecf130d8f3ea2d5edc70c9a479363142d3a6901b12ce422339bcf75a69b05e79b599a7b4d7812cc82b0d1a04647c246b2a0f4cbffaa7e5143 SHA512 b1e4a2641a731977a9116cb550df29bc329e72b528e6d7c6b809f95e5de249a985544d2eb58d18291ff46b99b7c35ffc4dc70081306dc69a1b907ac5ced8100b
MISC metadata.xml 556 BLAKE2B b8a8f2fd8ff23ea4bf828d0dbf673da0345f832124a526f533e4beb36ca168acb13bd4fd92e7842a5361c38d9437960322a0c29f4c11a79696ede0544148d2da SHA512 c7bec846363a0fb54edeb145718d0acf56e6c2d0c1b2eed68f24412a9f328dac86f78e39d636e0b234cd556c334fd413b810bb1e5689651a17e2cd31cae7bd8d
diff --git a/dev-python/geventhttpclient/geventhttpclient-1.5.2.ebuild b/dev-python/geventhttpclient/geventhttpclient-1.5.2.ebuild
new file mode 100644
index 000000000000..39d7cf97389c
--- /dev/null
+++ b/dev-python/geventhttpclient/geventhttpclient-1.5.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A high performance, concurrent HTTP client library for Python using gevent"
+HOMEPAGE="https://github.com/gwik/geventhttpclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/gevent[events(+),${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Avoid ModuleNotFoundError for tests we skip later
+ sed -i '/^import dpkt.ssl/d' src/geventhttpclient/tests/test_ssl.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # These SNI tests require dpkt which is not in the tree
+ src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_host_in_ssl
+ src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_header_in_ssl
+ src/geventhttpclient/tests/test_ssl.py::test_explicit_sni_in_ssl
+ )
+ # Append to sys.path to avoid ImportError
+ # https://bugs.gentoo.org/667758
+ # Skip tests which require internet access
+ epytest --import-mode=append -m "not online"
+}