summaryrefslogtreecommitdiff
path: root/dev-python/geventhttpclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-01 19:24:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-01 19:24:10 +0100
commitb052fbf151106a4f47cac7fdf0ffff983decb773 (patch)
tree5d21279a4eeaf4076caee87654b610a0fe8a4051 /dev-python/geventhttpclient
parentc3b55a6be7da027d97d8aef00ef88c3011121a42 (diff)
gentoo auto-resync : 01:09:2022 - 19:24:10
Diffstat (limited to 'dev-python/geventhttpclient')
-rw-r--r--dev-python/geventhttpclient/Manifest2
-rw-r--r--dev-python/geventhttpclient/geventhttpclient-2.0.2.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/geventhttpclient/Manifest b/dev-python/geventhttpclient/Manifest
index 3d0985e6b25f..f768d13f0bea 100644
--- a/dev-python/geventhttpclient/Manifest
+++ b/dev-python/geventhttpclient/Manifest
@@ -1,3 +1,5 @@
+DIST geventhttpclient-2.0.2.tar.gz 73821 BLAKE2B 6e12c0a7eabf2d15540192e161f27e4ef5aa771ac8b60deb00c0dbfd804e5d81f729609649c88b9b8cd51125b06afaf3d31367896ada339731ba3606ef64edda SHA512 d22453bc4fef8d9ad3b98a137d74df1647c69c594a8fa4b49848e71ca472373e44c70e3ed3798d73aca9089495cff1b5f888d1b1e39b1da60ee9052935b7b0a1
DIST geventhttpclient-2.0.tar.gz 73677 BLAKE2B b466f7153e646b3d9af0b301789aaa92df28dad505c375ec7fdcfb8d888d8942edba3f4c776ef4fc252756fb2a37bbee7d61c4a1e912c8c7d716a57fd49fee0e SHA512 1f53cf8636e6baba4cb0d8d7b233f903efec2d74413cfb2d768bff94f3a9b91ae59444981a1399b010e73120c390b52b1449424571c7ee9bdad818e5ce72ae8c
+EBUILD geventhttpclient-2.0.2.ebuild 1541 BLAKE2B 133d5086e2ac682cc5d41f6153f9579f4337ce70f6c5fe9844e38e5c86f5ef379b39a22480ff3a8c01df0c39b1fdc00ff7730d9719f322c756af3fbaa782e3ff SHA512 765b80365d81f20eded6be8ac7d3ef6dffe4dce45e938aa596c0e01a083501fb22c151500b3d10ed15d7e11e45f93e2f65333718ae00e70dbe017fcaa5870b8f
EBUILD geventhttpclient-2.0.ebuild 1537 BLAKE2B 1ef76232051fb2b29c2feefd2861a279ef6230f10c8d51a7653fb02d1d584b5d8d5766b301530b0df460bb873459a9482f02fb3538d982901a858c63746d4727 SHA512 830b8b365c850876e18de556f426e3ad061cff7c126b916dd662ee6ace14d1a83b733c0238fa33060e557f9a3ce78a5b4d3fc0b7ad15e7e160029852f50f6908
MISC metadata.xml 580 BLAKE2B 24b9860ee1f361f1ced81967a404c4cf773e415c053ac83ff0b2bb97bcbbaa5cbba4e7faddcb615379d3057d2c3c28d59f9c8a0a36135edf9165615610ecce45 SHA512 5c3a892358d1fc3594d08c3551b441eaa2e38c60cd06952a62631a4ac687ab730be559ecfb17f9ab7878d0052b4ff7e03d6d49fd1a277bff71c1ef4fc369daf8
diff --git a/dev-python/geventhttpclient/geventhttpclient-2.0.2.ebuild b/dev-python/geventhttpclient/geventhttpclient-2.0.2.ebuild
new file mode 100644
index 000000000000..5850080039c3
--- /dev/null
+++ b/dev-python/geventhttpclient/geventhttpclient-2.0.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A high performance, concurrent HTTP client library for Python using gevent"
+HOMEPAGE="
+ https://github.com/geventhttpclient/geventhttpclient/
+ https://pypi.org/project/geventhttpclient/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/gevent[events(+),${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Avoid ModuleNotFoundError for tests we skip later
+ sed -e '/^import dpkt.ssl/d' -i src/geventhttpclient/tests/test_ssl.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # These SNI tests require dpkt which is not in the tree
+ src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_host_in_ssl
+ src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_header_in_ssl
+ src/geventhttpclient/tests/test_ssl.py::test_explicit_sni_in_ssl
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # Skip tests which require internet access
+ epytest -m "not online"
+}