summaryrefslogtreecommitdiff
path: root/dev-python/geventhttpclient/geventhttpclient-1.4.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/geventhttpclient/geventhttpclient-1.4.3.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/geventhttpclient/geventhttpclient-1.4.3.ebuild')
-rw-r--r--dev-python/geventhttpclient/geventhttpclient-1.4.3.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/geventhttpclient/geventhttpclient-1.4.3.ebuild b/dev-python/geventhttpclient/geventhttpclient-1.4.3.ebuild
deleted file mode 100644
index 4d3f4094b52b..000000000000
--- a/dev-python/geventhttpclient/geventhttpclient-1.4.3.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} )
-
-inherit distutils-r1
-
-DESCRIPTION="A high performance, concurrent HTTP client library for Python using gevent"
-HOMEPAGE="https://github.com/gwik/geventhttpclient"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/certifi[${PYTHON_USEDEP}]
- dev-python/gevent[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- ${RDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-python_prepare_all() {
- # Skip SNI tests which require dpkt
- sed -i '/^import dpkt.ssl/d' src/geventhttpclient/tests/test_ssl.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local skipped_tests=(
- # Require dpkt
- src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_host_in_ssl
- src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_header_in_ssl
- src/geventhttpclient/tests/test_ssl.py::test_explicit_sni_in_ssl
- )
- # Append to sys.path to avoid ImportError
- # https://bugs.gentoo.org/667758
- # Skip tests which require internet access
- pytest --import-mode=append -vv ${skipped_tests[@]/#/--deselect } \
- -m "not online" || die "Tests failed with ${EPYTHON}"
-}