summaryrefslogtreecommitdiff
path: root/dev-python/gevent
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /dev-python/gevent
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'dev-python/gevent')
-rw-r--r--dev-python/gevent/Manifest2
-rw-r--r--dev-python/gevent/gevent-21.12.0.ebuild100
2 files changed, 102 insertions, 0 deletions
diff --git a/dev-python/gevent/Manifest b/dev-python/gevent/Manifest
index bc4cd3b5d3bb..2854efbc9ccc 100644
--- a/dev-python/gevent/Manifest
+++ b/dev-python/gevent/Manifest
@@ -1,3 +1,5 @@
+DIST gevent-21.12.0.tar.gz 6201851 BLAKE2B 8c02f42d6024e912e51754df876d4f4895acdf466f2400e9fdca69ad5c7c77df7ee05f3e4c2c1e1d5731c282b62d5c940d9ca6396c27d6fe6e8a0ec13013591c SHA512 805ddb475281b6c4c46cdf5a714915b6612512745121e7b153f3d33f3460135efa4994e0ff1601402d4f7b80d285cbfdc0d5d93799fbeb8ddbf2a52888cd91ad
DIST gevent-21.8.0.tar.gz 6162938 BLAKE2B f24770cdbf229d4a4ebe7e6c102c43ab0c89a52389ada40c8abaf032eada323333ca9ac965c65d335d96d69c97cdc239e193dd5a38076c81a2f3c80daa13b339 SHA512 dae95f986530e79b07a0006f6fb4cbd3911ac0bf2e58c4896ee5fa6d2e2a9ed5785c346958ee23cd57c2dcafb0a34c585b1f6375a29fd653e061a382482fc9fb
+EBUILD gevent-21.12.0.ebuild 2584 BLAKE2B 30a347ddca5618dcf2e1fecf0971ba6436865b982a288826eaac4ac7769e034d99aa11cea9ad4f339ae3612d167167414f9a9e896a4684a3016a1610e25e7b78 SHA512 930fc11441c84e954417cfab2ca5391885a00b06a95776790433200ee59f87ca6428949d317578cb4d834de56e371d725b7ff424f6aa9427479e5343f052b317
EBUILD gevent-21.8.0.ebuild 2172 BLAKE2B 057508152549d9b9bbfb7e38ef46a276204199bd404ec639c54518e6c54ed8c67e4aafc4fae084f6d0dce52874b857f7d639edaf30a3c8a4ab6ad81f123848db SHA512 1ea4b453ce2564405c189a53e31e1f99476ba1fac71e49e5726bf31dc0899fcf4f13acc4625f510bbc3b0ddb231cf05bbed24e79ccb179c3895c1bed7472fa3c
MISC metadata.xml 375 BLAKE2B 684f4f58e0d1f61195c30baa6b962f877ce7243305feb39a60a0a3dbd34e1095194be9b148644914bc1fbb74ac3bd5a692fd90343ccb9b2ec7bffd518ddd2492 SHA512 84242102ecfed7551ec1e95d3dee7ef56e154db34e3eb3e8255974ea48e879220b0b38acffa61a760521a1278c5074a20c22426e18bd0530935fbd671a2ea60d
diff --git a/dev-python/gevent/gevent-21.12.0.ebuild b/dev-python/gevent/gevent-21.12.0.ebuild
new file mode 100644
index 000000000000..0c7cee33a7e9
--- /dev/null
+++ b/dev-python/gevent/gevent-21.12.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+PYTHON_REQ_USE="ssl(+),threads(+)"
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Coroutine-based network library"
+HOMEPAGE="https://www.gevent.org/ https://pypi.org/project/gevent/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/libev-4.31:=
+ dev-libs/libuv:=
+ >=net-dns/c-ares-1.12:=
+"
+RDEPEND="${DEPEND}
+ virtual/python-greenlet[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx doc
+
+# Tests take long and fail terribly a few times.
+# It also seems that they require network access.
+#RESTRICT="test"
+
+python_prepare_all() {
+ export GEVENTSETUP_EMBED="false"
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ append-flags -fno-strict-aliasing
+}
+
+python_test() {
+ # Just in case.
+ export GEVENTTEST_USE_RESOURCES=-network
+
+ cd src/gevent/tests || die
+
+ # Tests which need network but aren't marked as such
+ echo "test__getaddrinfo_import.py" >> tests_that_dont_use_resolver.txt || die
+ echo "test_socketqcqqrwns.py" >> tests_that_dont_use_resolver.txt || die
+
+ # Test hangs (testPeek)
+ echo "test_socket.py" >> tests_that_dont_use_resolver.txt || die
+
+ # TODO: figure out how to make them work and not hang
+ #GEVENT_RESOLVER=ares \
+ # "${EPYTHON}" -m gevent.tests \
+ # --verbose \
+ # -uall,-network \
+ # --config known_failures.py \
+ # --ignore tests_that_dont_use_resolver.txt || die
+ GEVENT_RESOLVER=dnspython \
+ "${EPYTHON}" -m gevent.tests \
+ --verbose \
+ -uall,-network \
+ --config known_failures.py \
+ --ignore tests_that_dont_use_resolver.txt || die
+ GEVENT_RESOLVER=thread \
+ "${EPYTHON}" -m gevent.tests \
+ --verbose \
+ -uall,-network \
+ --config known_failures.py \
+ --ignore tests_that_dont_use_resolver.txt || die
+ GEVENT_FILE=thread \
+ "${EPYTHON}" -m gevent.tests \
+ --verbose \
+ -uall,-network \
+ --config known_failures.py \
+ test__*subprocess*.py || die
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS README.rst )
+ use examples && dodoc -r examples
+
+ distutils-r1_python_install_all
+}