summaryrefslogtreecommitdiff
path: root/dev-python/gevent/gevent-20.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-python/gevent/gevent-20.6.1.ebuild
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-python/gevent/gevent-20.6.1.ebuild')
-rw-r--r--dev-python/gevent/gevent-20.6.1.ebuild90
1 files changed, 90 insertions, 0 deletions
diff --git a/dev-python/gevent/gevent-20.6.1.ebuild b/dev-python/gevent/gevent-20.6.1.ebuild
new file mode 100644
index 000000000000..0ada47ba7720
--- /dev/null
+++ b/dev-python/gevent/gevent-20.6.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} )
+PYTHON_REQ_USE="ssl(+),threads(+)"
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Coroutine-based network library"
+HOMEPAGE="http://gevent.org/ https://pypi.org/project/gevent/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/libev-4.23:=
+ dev-libs/libuv:=
+ >=net-dns/c-ares-1.12:=
+ >=dev-python/greenlet-0.4.14
+ virtual/python-greenlet[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/futures[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ ' -2)
+ )"
+
+distutils_enable_sphinx doc
+
+# Tests take long and fail terribly a few times.
+# It also seems that they require network access.
+#RESTRICT="test"
+
+python_prepare_all() {
+ export LIBEV_EMBED="false"
+ export CARES_EMBED="false"
+ export EMBED="false"
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ append-flags -fno-strict-aliasing
+}
+
+python_test() {
+ cd src/gevent/tests || die
+ # TODO: figure out how to make them work and not hang
+# GEVENT_RESOLVER=ares \
+# "${EPYTHON}" -m gevent.tests \
+# -uall,-network \
+# --config known_failures.py \
+# --ignore tests_that_dont_use_resolver.txt || die
+# GEVENT_RESOLVER=dnspython \
+# "${EPYTHON}" -m gevent.tests \
+# -uall,-network \
+# --config known_failures.py \
+# --ignore tests_that_dont_use_resolver.txt || die
+# GEVENT_RESOLVER=thread \
+# "${EPYTHON}" -m gevent.tests \
+# --verbose \
+# -uall,-network \
+# --config known_failures.py \
+# --ignore tests_that_dont_use_resolver.txt || die
+ GEVENT_FILE=thread \
+ "${EPYTHON}" -m gevent.tests \
+ --verbose \
+ -uall,-network \
+ --config known_failures.py \
+ test__*subprocess*.py || die
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS README.rst )
+ use examples && dodoc -r examples
+
+ distutils-r1_python_install_all
+}