summaryrefslogtreecommitdiff
path: root/dev-python/geopy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/geopy
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/geopy')
-rw-r--r--dev-python/geopy/Manifest3
-rw-r--r--dev-python/geopy/geopy-1.11.0.ebuild66
-rw-r--r--dev-python/geopy/metadata.xml17
3 files changed, 0 insertions, 86 deletions
diff --git a/dev-python/geopy/Manifest b/dev-python/geopy/Manifest
deleted file mode 100644
index 5c0c7b3e97dd..000000000000
--- a/dev-python/geopy/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST geopy-1.11.0.tar.gz 72035 BLAKE2B 9d0ab7407f629ccc942e55d3529dbcfa792c50046aad7a23801803085f21675ed4bb3b734c430c5f7842a6f1f69d679a5ab9b37e4e60eefd48efa30a11468557 SHA512 b3abbf0ce4ca08eadc03a97876a662bbda1901660ea03329aace30bfb5f8af17c82653273e4d2eab9aca5e817f50768dd742b4865083709e10b8599331d5573b
-EBUILD geopy-1.11.0.ebuild 2291 BLAKE2B dae6426d50b71e33b8529c380e04d6137b8c07bef2a56332c34d410c83009f9b4764ffed5cfb32532217821fdf12071f99b76edf7bb1955cdc88329c1c11d5f8 SHA512 6e7dd83a59537d0665d3cb90483d3287d54753c9069a52ef2ddfdfbb437956d0538c5583aa496e756afac680a235761e8def6e31161a93378b8f27bf3b04c7c9
-MISC metadata.xml 566 BLAKE2B ea35386f802c3a3d619e8531eabad55dfcc4da3ce7895859aab57bba610f52bee9f026513ca8a983a19a7eb52e6464240d629577381e1ba0030dfd4c8577a659 SHA512 37c883926b9a90ea8357aa2c307bef10ce6f419acb6bae4f4bef43604e699476dc1d5a258a3279e3b029d16097168bda3beeec924111fbe185be82017dbb8843
diff --git a/dev-python/geopy/geopy-1.11.0.ebuild b/dev-python/geopy/geopy-1.11.0.ebuild
deleted file mode 100644
index cac709dd0f81..000000000000
--- a/dev-python/geopy/geopy-1.11.0.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="A Geocoding Toolbox for Python"
-HOMEPAGE="http://www.geopy.org/ https://github.com/geopy/geopy"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-IUSE="test doc timezone yahoo"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="yahoo? ( >=dev-python/requests-oauthlib-0.4.0[${PYTHON_USEDEP}]
- dev-python/placefinder[${PYTHON_USEDEP}] )
- timezone? ( dev-python/pytz[${PYTHON_USEDEP}] )"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/nose-cover3[${PYTHON_USEDEP}]
- dev-python/pylint[${PYTHON_USEDEP}] )
- doc? ( $(python_gen_cond_dep 'dev-python/sphinx[${PYTHON_USEDEP}]' python2_7)
- >=dev-python/python-docs-2.7.6-r1:2.7 )"
-
-REQUIRED_USE="test? ( yahoo timezone )"
-
-python_prepare_all() {
- if use doc; then
- local PYTHON_DOC_ATOM=$(best_version --host-root dev-python/python-docs:2.7)
- local PYTHON_DOC_VERSION="${PYTHON_DOC_ATOM#dev-python/python-docs-}"
- local PYTHON_DOC="/usr/share/doc/python-docs-${PYTHON_DOC_VERSION}/html"
- local PYTHON_DOC_INVENTORY="${PYTHON_DOC}/objects.inv"
- sed -i "s|'http://docs.python.org/': None|'${PYTHON_DOC}': '${PYTHON_DOC_INVENTORY}'|" docs/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-
- # prevent install of test folder to avoid file collisions
- sed -e "s:find_packages():find_packages(exclude=['test','test.*']):" -i setup.py || die
-}
-
-python_test() {
- # broken tests
- rm test/geocoders/openmapquest.py
- sed -i -e 's/from .openmapquest import OpenMapQuestTestCase//' test/geocoders/__init__.py
- # Ignore rogue class IGNFranceTestCase demanding elements beyond a normal testsuite
- # i.e. "You should provide an api key and a username with a password"
- # Cannot decipher how to skip or exclude this "context=IGNFranceTestCase"
- # It appears it MAY stem from nose rather than geopy's suite
- nosetests --verbose || die "Tests failed under ${EPYTHON}"
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/geopy/metadata.xml b/dev-python/geopy/metadata.xml
deleted file mode 100644
index 8e4022f6fcb3..000000000000
--- a/dev-python/geopy/metadata.xml
+++ /dev/null
@@ -1,17 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="google-code">geopy</remote-id>
- <remote-id type="pypi">geopy</remote-id>
- <remote-id type="github">geopy/geopy</remote-id>
- </upstream>
- <use>
- <flag name="yahoo">Enables use of YahooPlaceFinder</flag>
- <flag name="timezone">Enables localized date support</flag>
- </use>
-</pkgmetadata>