summaryrefslogtreecommitdiff
path: root/dev-python/geoip-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/geoip-python
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/geoip-python')
-rw-r--r--dev-python/geoip-python/Manifest4
-rw-r--r--dev-python/geoip-python/geoip-python-1.3.2-r1.ebuild42
-rw-r--r--dev-python/geoip-python/geoip-python-1.3.2.ebuild43
-rw-r--r--dev-python/geoip-python/metadata.xml12
4 files changed, 101 insertions, 0 deletions
diff --git a/dev-python/geoip-python/Manifest b/dev-python/geoip-python/Manifest
new file mode 100644
index 000000000000..3ee1a2f67300
--- /dev/null
+++ b/dev-python/geoip-python/Manifest
@@ -0,0 +1,4 @@
+DIST geoip-api-python-1.3.2.tar.gz 35674 BLAKE2B c6c4469164347c8c1a8a5231be25370e806768d7f155832cf759469320d8adbd5efcd002d14d1d95522e8bcb4db12668b28b437b45af669bb336024662908498 SHA512 284209a6894d55ef95844c5c4c7aafff99ebcb13996e5ff64a0c31b38677e13c11d51fd8b0250d0fa097f15805c27b572d5aa12c2b217a839afe3cdd0851c414
+EBUILD geoip-python-1.3.2-r1.ebuild 905 BLAKE2B 084676c55820b3d704aea1ff935d11dc558dc42d09e92a80fe08e0a426ad59931ad9aedaa838b6c84a974208d503d6b8ed00e1971372448701b6df1f78c19c64 SHA512 e71a1c2b572ad444c388997ae11c37c78661f4cc4a25eff1fdb5f33285c6e9823d82d435616e5bf60417a4df13b05df1be436eecca5b5bb89308fa04d165ab09
+EBUILD geoip-python-1.3.2.ebuild 972 BLAKE2B a975ea9b9e62215a95ff915e20a73c566799fc2453bacf427269a6db152d4129b88f2703a0d36a1e63d6130f2e8b71d328a89c71334827fe013e042a6603043b SHA512 6a058db575e1370c2b2d261e83cc0632c86cb3df41324555699bfbc5824bcd61b72810a423f25e1b5c868bdf022ac8d0913973fee474eace182339247a717923
+MISC metadata.xml 372 BLAKE2B a64a0eafc20c11334ab112844de60a58eeaec62d2bb88ceb0e72efba9fae4cfd0bb02a169f4913299534cf3243d740a6f0f96fee1448a55bb8d9bffe3ccf3597 SHA512 dfcd2454bac4830995eda03b9fc585ea4f19f3e5fc90c00b57ee75d8d9596dc5dda9294f770481df7b9c6e27dea45f7fcf1f8d6094703121b0eab62f2fb055a0
diff --git a/dev-python/geoip-python/geoip-python-1.3.2-r1.ebuild b/dev-python/geoip-python/geoip-python-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..06fb375a9292
--- /dev/null
+++ b/dev-python/geoip-python/geoip-python-1.3.2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="geoip-api-python"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python bindings for GeoIP"
+HOMEPAGE="https://github.com/maxmind/geoip-api-python"
+SRC_URI="https://github.com/maxmind/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ~ppc ~sparc x86 ~x86-fbsd"
+IUSE="examples test"
+
+RDEPEND=">=dev-libs/geoip-1.4.8"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( README.rst ChangeLog.md )
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/geoip-python/geoip-python-1.3.2.ebuild b/dev-python/geoip-python/geoip-python-1.3.2.ebuild
new file mode 100644
index 000000000000..16ee2baa878a
--- /dev/null
+++ b/dev-python/geoip-python/geoip-python-1.3.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="geoip-api-python"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python bindings for GeoIP"
+HOMEPAGE="https://github.com/maxmind/geoip-api-python"
+SRC_URI="https://github.com/maxmind/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc ~sparc x86 ~x86-fbsd"
+IUSE="examples test"
+
+RDEPEND=">=dev-libs/geoip-1.4.8"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( README.rst ChangeLog.md )
+
+python_compile() {
+ if [[ python_is_python3 || "$EPYTHON}" == 'pypy3' ]]; then
+ local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/geoip-python/metadata.xml b/dev-python/geoip-python/metadata.xml
new file mode 100644
index 000000000000..362cd6be0d48
--- /dev/null
+++ b/dev-python/geoip-python/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">maxmind/geoip-api-python</remote-id>
+ <remote-id type="pypi">GeoIP</remote-id>
+ </upstream>
+</pkgmetadata>