summaryrefslogtreecommitdiff
path: root/dev-python/gdb-pt-dump
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-10 12:30:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-10 12:30:41 +0100
commitadd278b9601ff9e4af091c91c851ee46a185be8f (patch)
tree4b654beae0eec584ae1d1f3227a57607d591a0ea /dev-python/gdb-pt-dump
parentd8a7472fc6314625f7d16e0427004eb448412908 (diff)
gentoo auto-resync : 10:09:2024 - 12:30:41
Diffstat (limited to 'dev-python/gdb-pt-dump')
-rw-r--r--dev-python/gdb-pt-dump/Manifest4
-rw-r--r--dev-python/gdb-pt-dump/gdb-pt-dump-0.0.0_p20240401.ebuild31
-rw-r--r--dev-python/gdb-pt-dump/gdb-pt-dump-9999.ebuild2
3 files changed, 35 insertions, 2 deletions
diff --git a/dev-python/gdb-pt-dump/Manifest b/dev-python/gdb-pt-dump/Manifest
index f8cfbcfa1e6e..7b6fd842505c 100644
--- a/dev-python/gdb-pt-dump/Manifest
+++ b/dev-python/gdb-pt-dump/Manifest
@@ -1,4 +1,6 @@
DIST gdb-pt-dump-0.0.0_p20231111.gh.tar.gz 386894 BLAKE2B 31c15a7574ac37e859831e6b17d27ce47bc6aed4d3bb81a01c8492b803cd71ba28379777bd9c221c9f81585811bba4952fb8e5349104ff36e88efe3996715937 SHA512 c94cce47754b634a2fda267f715cdd7957ec0714c4ac96d6b9e20fa4cfdf6c026a3e0b351bf0e041ea0c2dbf253f547ede3d2b13b83c6316ef6222bac0e4b61b
+DIST gdb-pt-dump-0.0.0_p20240401.gh.tar.gz 406426 BLAKE2B 9b50d600df72eec81b2d146dc972a2096ce6d8a085b79360dfefc3d45a733e29008ca3986496811532e541deec46d71410191869cd9643c603a3955d683e6ff7 SHA512 bb521868ccfbae8a411bc57e067cdda227b113cb20bc97eefad77a693f66d00d20debbce51f69c8daf86128bbf938cd3304ea97992aa817a608ce65f80173e10
EBUILD gdb-pt-dump-0.0.0_p20231111.ebuild 797 BLAKE2B d7c710ab859b6f86d7a99246c4d956b55df6c31ede7a7148242303e0b3dbe2275198ae2739fda0eb44fd8ce524098aed45801feff42764011d81b8de59f346a4 SHA512 e0491158ab7a4e41000748925df09c282a264624a262170fec3d8e99463a10a316a0483e2bd6957f74a00f0dc6e1bd8ff9f4238a22d49f110038768b0791fb0a
-EBUILD gdb-pt-dump-9999.ebuild 792 BLAKE2B 6045b8f3ca67bd9dcc9e5efe75886a11fed59ede48b6038012c518442f03bfc8c569c1e5349dd93e900ed9eaed1572482a24c872efe7d6b20bb95771ea019824 SHA512 6925a8bf62f9f1a7995c936ff91514573d7a98135b7133986327588a57937bfc4ecd722ce629a50e9915c07a812643f58bb451a29ecd7a255bdd21a396ae5ac0
+EBUILD gdb-pt-dump-0.0.0_p20240401.ebuild 799 BLAKE2B 63e1c05e90e0466822cc3892cf6774f9719dad2acfead78dfa93094387f6dd1ce387c564bd02801f2c2eea78e0ef0cec97122bd74509488c78f991d3fcdb2581 SHA512 15635c1261dddd7f967c7b0f0b56b141355476139fb0a626874083599ad5bafb2a6f190129a08fa6ad58193f663f6818ec0fe0938967d2bc4ee4e081f4f2b763
+EBUILD gdb-pt-dump-9999.ebuild 799 BLAKE2B ceffb88994559fe12aeeb77144f909b1156fd069bcbbcc87020cf867938cb4972ff63d5bd61e0e1d8655f9b7f0d8b19021f25815165a77a08d6aefa29c62625f SHA512 32453259953514a17379eaaf491be1ee368a9c8be00f1fb55e72c7aa7b7d8cc624751022ba8acfa5f43f3e65ab43cfb392c3727c9ec39fe10f0a7cd9767d1fb7
MISC metadata.xml 499 BLAKE2B 73e9944ab68c0e1a1c86b9afc9293d56d59cf7d3c31de8ba6c60c0ddcf26ce5dee238a0a6ead14b6e1a4d1ca675ccfd0f64856689609169b29d115b1f71d7f13 SHA512 d6df7350b7947f9f70a83e8eb9bea4774183bf55697f4e7131330cf11372d5af86d03c70d2a27c689759155c4f276ad36738fb324163cc2a13f4249271d906f6
diff --git a/dev-python/gdb-pt-dump/gdb-pt-dump-0.0.0_p20240401.ebuild b/dev-python/gdb-pt-dump/gdb-pt-dump-0.0.0_p20240401.ebuild
new file mode 100644
index 000000000000..3c950733ea16
--- /dev/null
+++ b/dev-python/gdb-pt-dump/gdb-pt-dump-0.0.0_p20240401.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Examine the address space of a QEMU-based virtual machine"
+HOMEPAGE="https://github.com/martinradev/gdb-pt-dump"
+
+GDB_PT_DUMP_COMMIT="50227bda0b6332e94027f811a15879588de6d5cb"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/martinradev/gdb-pt-dump.git"
+else
+ SRC_URI="https://github.com/martinradev/gdb-pt-dump/archive/${GDB_PT_DUMP_COMMIT}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ S="${WORKDIR}/${PN}-${GDB_PT_DUMP_COMMIT}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-debug/gdb[python,${PYTHON_SINGLE_USEDEP}]
+"
diff --git a/dev-python/gdb-pt-dump/gdb-pt-dump-9999.ebuild b/dev-python/gdb-pt-dump/gdb-pt-dump-9999.ebuild
index 306e29d54100..5bb5e7fcecfd 100644
--- a/dev-python/gdb-pt-dump/gdb-pt-dump-9999.ebuild
+++ b/dev-python/gdb-pt-dump/gdb-pt-dump-9999.ebuild
@@ -19,7 +19,7 @@ if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/martinradev/gdb-pt-dump.git"
else
SRC_URI="https://github.com/martinradev/gdb-pt-dump/archive/${GDB_PT_DUMP_COMMIT}.tar.gz -> ${P}.gh.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~arm64 ~x86"
S="${WORKDIR}/${PN}-${GDB_PT_DUMP_COMMIT}"
fi