summaryrefslogtreecommitdiff
path: root/dev-python/gast
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-21 02:09:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-21 02:09:25 +0000
commitafcb9236a72cf602364c28b9bde6648e4a7f1ca5 (patch)
tree9608aa2c881b2688207832334c938f0e38d5c71c /dev-python/gast
parentd3419aa304ff2564036398be5e8ed4bdeaeaa007 (diff)
gentoo auto-resync : 21:01:2024 - 02:09:25
Diffstat (limited to 'dev-python/gast')
-rw-r--r--dev-python/gast/Manifest2
-rw-r--r--dev-python/gast/gast-0.5.4.ebuild18
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/gast/Manifest b/dev-python/gast/Manifest
index 47ee2948faf6..2201a81144fd 100644
--- a/dev-python/gast/Manifest
+++ b/dev-python/gast/Manifest
@@ -1,3 +1,5 @@
DIST gast-0.5.3.tar.gz 23455 BLAKE2B b7263e959178421a7ba1cdb41cb09edbe1c30680573e1ab3b4de114e0bd151d2278be799fcc1a01524bb5ee6f6d6764d9902dd0018e7cbe54ac7a3d1300bbeb1 SHA512 a836be76303591ca7c40596d98a29dbd53f281e277c8c23e3821b2003d4e8aaf4d806e7f532f27c0eadd4bdca5a28dc0a3902245505ab97497b9afbfee0c2e52
+DIST gast-0.5.4.tar.gz 25346 BLAKE2B c7161737367c2a3335d9e51af1dc09934ea16694d497cb151ed713b3372666456b5dcc2c595294c7162035af29d454bad5c8fb677030de9235c52d5ff8a3f05b SHA512 a288e2ecc15af2a5d50cb34979995f936e88cdaa4427f809b69015cb6ba98eaffd7ea9eff2dc61dae6f6c2d7d9c5cc6e3e9a5565bd7b1dd308cd39f56087c67d
EBUILD gast-0.5.3-r1.ebuild 507 BLAKE2B 88f34341106855f986c6e1e0445c653437fc45fc6434f73d06dcfa128b500cdbec5a49f5d38337ad358c1ee234a9da9ca973e26acc30b1756944e85ab49b9597 SHA512 c9ab37e0685f52dce31f28a18861eb58670006d88487a2a90ba8918add0aabed7d6d003e7cbd9c1a5c189bf02b640bc07e100bdf7360814dae687853c9969d7f
+EBUILD gast-0.5.4.ebuild 513 BLAKE2B 5ba305e79b003b74f182e11ee269c3b05a4ac8284751416694978c5f825262a43f1bf816abe96bf49c3c1528430207deb8309c8c6628c226840699762fd60eb2 SHA512 a017df1ff599a1b4c81e030872ed4754857ae7796ab5762a7773a81044d2e2dbca6234cfc50ce8278cbbb67d503be770db909a7d0e46c3038440421084b8c82f
MISC metadata.xml 739 BLAKE2B 6a226f9d712552a98ff4e7562da4097bb307fc7641085f45aed3f8610fefcb01e8458e96a5e46af30e3e01574415149269dcf5222229290225dd5f02543959b0 SHA512 02f9b1a30219372f6b769158ff9fb096a74f7d8ee6b67f5f9ad23ff382ce450767867a4074e04b1d5ac77e1987c3e9b661630e7626b68f8b5270032d7684161d
diff --git a/dev-python/gast/gast-0.5.4.ebuild b/dev-python/gast/gast-0.5.4.ebuild
new file mode 100644
index 000000000000..c7494e489742
--- /dev/null
+++ b/dev-python/gast/gast-0.5.4.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A generic AST to represent Python2 and Python3's Abstract Syntax Tree (AST)"
+HOMEPAGE="https://pypi.org/project/gast/"
+
+LICENSE="BSD PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+distutils_enable_tests unittest