summaryrefslogtreecommitdiff
path: root/dev-python/gast/gast-0.5.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-30 11:17:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-30 11:17:10 +0100
commit200338d9ebd0cd0599af59f208eb58f48f5ae168 (patch)
tree03aa7ba96612219b7aeb018639ba95924c0f1d81 /dev-python/gast/gast-0.5.4.ebuild
parenta9a8100d7a659b808e3a112a113b65e16f0070c3 (diff)
gentoo auto-resync : 30:04:2023 - 11:17:09
Diffstat (limited to 'dev-python/gast/gast-0.5.4.ebuild')
-rw-r--r--dev-python/gast/gast-0.5.4.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/gast/gast-0.5.4.ebuild b/dev-python/gast/gast-0.5.4.ebuild
new file mode 100644
index 000000000000..b6c2631556e1
--- /dev/null
+++ b/dev-python/gast/gast-0.5.4.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A generic AST to represent Python2 and Python3's Abstract Syntax Tree (AST)"
+HOMEPAGE="
+ https://github.com/serge-sans-paille/gast/
+ https://pypi.org/project/gast/
+"
+
+LICENSE="BSD PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests unittest