summaryrefslogtreecommitdiff
path: root/dev-python/gast/gast-0.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
commit9aa80713372911cec499b3adb2cd746790920916 (patch)
treeb8e99dc5dd60ac2094a27cc52f74aada8df38f05 /dev-python/gast/gast-0.5.0.ebuild
parentb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (diff)
gentoo resync : 29.06.2021
Diffstat (limited to 'dev-python/gast/gast-0.5.0.ebuild')
-rw-r--r--dev-python/gast/gast-0.5.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/gast/gast-0.5.0.ebuild b/dev-python/gast/gast-0.5.0.ebuild
new file mode 100644
index 000000000000..f25219967d31
--- /dev/null
+++ b/dev-python/gast/gast-0.5.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A generic AST to represent Python2 and Python3's Abstract Syntax Tree (AST)"
+HOMEPAGE="https://pypi.org/project/gast/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? ( dev-python/astunparse[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests unittest