summaryrefslogtreecommitdiff
path: root/dev-python/future
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-python/future
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-python/future')
-rw-r--r--dev-python/future/Manifest3
-rw-r--r--dev-python/future/files/future-0.18.2-py39.patch65
-rw-r--r--dev-python/future/future-0.18.2.ebuild4
3 files changed, 69 insertions, 3 deletions
diff --git a/dev-python/future/Manifest b/dev-python/future/Manifest
index 3061fcd7e7e5..60967c1558f4 100644
--- a/dev-python/future/Manifest
+++ b/dev-python/future/Manifest
@@ -1,4 +1,5 @@
+AUX future-0.18.2-py39.patch 2789 BLAKE2B db6c0cb0a030d166f01b95721e560d346f8a80ec63f81c58e5fca663f975b8f8f771d169742a421c34c08b0de01069bb5455b5fafdab440af6e73746df0bb24c SHA512 7bb140d526d2e728d5a988898977e8bf87934f68c42a38f97717b3e5fc040ddc736cdb2b366a8dbbb95c857bffee9f448ff1883dff9c61cb46582d3a01aad65f
AUX future-0.18.2-tests.patch 11773 BLAKE2B e2b9321ab2a04e4567c312beaccd23886c87f8b78c1de5d480205181a68b77d8c8b1582a57f43e510d5cd3ecc54252bb85130fe6d7e82756c9f1db11263fdf7b SHA512 d884d6b4e320a6e2aeca2c0c46576d9b0fd0d31aaa6f8f9a79f2007ecbc949f1393aa0b9254f0c51616ca4e8d3fb3f11d828879e4e8c01549acd4ecf04e2cf68
DIST future-0.18.2.tar.gz 829220 BLAKE2B 68574b589bf54aa8dacbd162a54885589faa32829ccf212f50de5bf036ebd8b9aba0c13e63e80d34e507cc0dae4d8d3d47fea33433b17d2c2e6dbf6c37f66d8f SHA512 91c025f7d94bcdf93df838fab67053165a414fc84e8496f92ecbb910dd55f6b6af5e360bbd051444066880c5a6877e75157bd95e150ead46e5c605930dfc50f2
-EBUILD future-0.18.2.ebuild 1031 BLAKE2B dfdfa275a489efb5e33fd2905bf5b87d0700d50685bc01b36e205610018248800441216c42a1fc999ccc93b40b48c4fbff02a29c5dbb0aed6efcd226710b9f50 SHA512 d197595b5efe9174ecaf58d5bd27c6cfc4a3390fbafd85b07afb7ed855373ecbc3fd986bc5ce9b7ebc6021d21f8a755996848fc33928249e92ae1b37eb7c7afc
+EBUILD future-0.18.2.ebuild 1006 BLAKE2B bf9ee46921dc5ad78b9de4cca401cbc98ff6c0dff1962cffe578fa28bb04ee54cd0acdddc45c67294f3acc798badcabe01803afc21ab6b7ec49c85fe5f7f2694 SHA512 78316a6f77eb064e2c254e531ed031d15bdfdca666ddd7e9f4a862f5fbf116475e9ad3dd103bec99e29c95134cb8793a504dd760395ac25b78501448746cd6f2
MISC metadata.xml 309 BLAKE2B ac0715185226cea8e3c38698ed3e494b6464d86dad0211e4d0583e3ceb6634c2b1ec230d9dff659d5ef47208b6f3358c701a0c42e49848816ae99703cab82f46 SHA512 e01e3b2733211e1eb6aaef4da19265c7165411a46fde4c2156118700c315bc2ad52cd87de1b90355741de77d91aa22eed5f9e5847d45186bf7138d246cd775e4
diff --git a/dev-python/future/files/future-0.18.2-py39.patch b/dev-python/future/files/future-0.18.2-py39.patch
new file mode 100644
index 000000000000..4524cb0c093b
--- /dev/null
+++ b/dev-python/future/files/future-0.18.2-py39.patch
@@ -0,0 +1,65 @@
+From edda349a2d4fffa6c7f277483ccb40a66c0795b9 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
+Date: Mon, 10 Feb 2020 23:17:28 +0100
+Subject: [PATCH] Test fixes for Python 3.9
+
+Fixes https://github.com/PythonCharmers/python-future/issues/540
+Fixes https://github.com/PythonCharmers/python-future/issues/541
+---
+ src/future/moves/_dummy_thread.py | 2 +-
+ src/future/standard_library/__init__.py | 2 +-
+ tests/test_future/test_standard_library.py | 1 -
+ tests/test_future/test_urllib_toplevel.py | 2 --
+ 4 files changed, 2 insertions(+), 5 deletions(-)
+
+diff --git a/src/future/moves/_dummy_thread.py b/src/future/moves/_dummy_thread.py
+index 688d249b..cc2fc891 100644
+--- a/src/future/moves/_dummy_thread.py
++++ b/src/future/moves/_dummy_thread.py
+@@ -2,7 +2,7 @@
+ from future.utils import PY3
+
+ if PY3:
+- from _dummy_thread import *
++ from _thread import *
+ else:
+ __future_module__ = True
+ from dummy_thread import *
+diff --git a/src/future/standard_library/__init__.py b/src/future/standard_library/__init__.py
+index cff02f95..3e8da8a6 100644
+--- a/src/future/standard_library/__init__.py
++++ b/src/future/standard_library/__init__.py
+@@ -125,7 +125,7 @@
+ # 'Tkinter': 'tkinter',
+ '_winreg': 'winreg',
+ 'thread': '_thread',
+- 'dummy_thread': '_dummy_thread',
++ 'dummy_thread': '_thread',
+ # 'anydbm': 'dbm', # causes infinite import loop
+ # 'whichdb': 'dbm', # causes infinite import loop
+ # anydbm and whichdb are handled by fix_imports2
+diff --git a/tests/test_future/test_standard_library.py b/tests/test_future/test_standard_library.py
+index 3ac5d2d7..8ab27a27 100644
+--- a/tests/test_future/test_standard_library.py
++++ b/tests/test_future/test_standard_library.py
+@@ -422,7 +422,6 @@ def test_urllib_imports_install_hooks(self):
+
+ def test_underscore_prefixed_modules(self):
+ import _thread
+- import _dummy_thread
+ import _markupbase
+ self.assertTrue(True)
+
+diff --git a/tests/test_future/test_urllib_toplevel.py b/tests/test_future/test_urllib_toplevel.py
+index 11e77201..25f4ca82 100644
+--- a/tests/test_future/test_urllib_toplevel.py
++++ b/tests/test_future/test_urllib_toplevel.py
+@@ -781,8 +781,6 @@ def test_unquoting(self):
+ "%s" % result)
+ self.assertRaises((TypeError, AttributeError), urllib_parse.unquote, None)
+ self.assertRaises((TypeError, AttributeError), urllib_parse.unquote, ())
+- with support.check_warnings(('', BytesWarning), quiet=True):
+- self.assertRaises((TypeError, AttributeError), urllib_parse.unquote, bytes(b''))
+
+ def test_unquoting_badpercent(self):
+ # Test unquoting on bad percent-escapes
diff --git a/dev-python/future/future-0.18.2.ebuild b/dev-python/future/future-0.18.2.ebuild
index 1107c385f9c5..d30157b8e138 100644
--- a/dev-python/future/future-0.18.2.ebuild
+++ b/dev-python/future/future-0.18.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -24,10 +24,10 @@ distutils_enable_sphinx docs dev-python/sphinx-bootstrap-theme
PATCHES=(
"${FILESDIR}"/${P}-tests.patch
+ "${FILESDIR}"/${P}-py39.patch
)
python_prepare_all() {
- sed -i "/'sphinx.ext.intersphinx'/d" docs/conf.py || die
# tests requiring network access
rm tests/test_future/test_requests.py || die
sed -i -e 's:test.*request_http:_&:' \