summaryrefslogtreecommitdiff
path: root/dev-python/future
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/future
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/future')
-rw-r--r--dev-python/future/Manifest2
-rw-r--r--dev-python/future/future-0.18.2.ebuild17
2 files changed, 6 insertions, 13 deletions
diff --git a/dev-python/future/Manifest b/dev-python/future/Manifest
index 8b3bb63c6a29..3061fcd7e7e5 100644
--- a/dev-python/future/Manifest
+++ b/dev-python/future/Manifest
@@ -1,4 +1,4 @@
AUX future-0.18.2-tests.patch 11773 BLAKE2B e2b9321ab2a04e4567c312beaccd23886c87f8b78c1de5d480205181a68b77d8c8b1582a57f43e510d5cd3ecc54252bb85130fe6d7e82756c9f1db11263fdf7b SHA512 d884d6b4e320a6e2aeca2c0c46576d9b0fd0d31aaa6f8f9a79f2007ecbc949f1393aa0b9254f0c51616ca4e8d3fb3f11d828879e4e8c01549acd4ecf04e2cf68
DIST future-0.18.2.tar.gz 829220 BLAKE2B 68574b589bf54aa8dacbd162a54885589faa32829ccf212f50de5bf036ebd8b9aba0c13e63e80d34e507cc0dae4d8d3d47fea33433b17d2c2e6dbf6c37f66d8f SHA512 91c025f7d94bcdf93df838fab67053165a414fc84e8496f92ecbb910dd55f6b6af5e360bbd051444066880c5a6877e75157bd95e150ead46e5c605930dfc50f2
-EBUILD future-0.18.2.ebuild 1112 BLAKE2B 22a8fb95c1807fa3697912e2942219f567c34d22c796a49f5535f010d47401bffe335438452619c42ddc0b427fe5dbb9fa9a569209f40095d7cc471b2dadc040 SHA512 c213a6c39a23f2c99f05c15b587aeddf5c73d7aee6a28467aa4f4c7f0c40ef840fa108e12d1f403492d86f798b32eb6f6052ae835bb17d94a45b43f125dc78df
+EBUILD future-0.18.2.ebuild 1031 BLAKE2B dfdfa275a489efb5e33fd2905bf5b87d0700d50685bc01b36e205610018248800441216c42a1fc999ccc93b40b48c4fbff02a29c5dbb0aed6efcd226710b9f50 SHA512 d197595b5efe9174ecaf58d5bd27c6cfc4a3390fbafd85b07afb7ed855373ecbc3fd986bc5ce9b7ebc6021d21f8a755996848fc33928249e92ae1b37eb7c7afc
MISC metadata.xml 309 BLAKE2B ac0715185226cea8e3c38698ed3e494b6464d86dad0211e4d0583e3ceb6634c2b1ec230d9dff659d5ef47208b6f3358c701a0c42e49848816ae99703cab82f46 SHA512 e01e3b2733211e1eb6aaef4da19265c7165411a46fde4c2156118700c315bc2ad52cd87de1b90355741de77d91aa22eed5f9e5847d45186bf7138d246cd775e4
diff --git a/dev-python/future/future-0.18.2.ebuild b/dev-python/future/future-0.18.2.ebuild
index 5e88bab00882..1107c385f9c5 100644
--- a/dev-python/future/future-0.18.2.ebuild
+++ b/dev-python/future/future-0.18.2.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-
PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -16,18 +16,11 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
IUSE="doc"
+# TODO: restore numpy when python2.7 is gone
+#BDEPEND="test? ( dev-python/numpy[${PYTHON_USEDEP}] )"
+
distutils_enable_tests pytest
-distutils_enable_sphinx docs \
- dev-python/sphinx-bootstrap-theme
-
-# TODO: make numpy unconditional when it supports py3.8
-BDEPEND+="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' \
- python{2_7,3_{5,6,7}})
- )
-"
+distutils_enable_sphinx docs dev-python/sphinx-bootstrap-theme
PATCHES=(
"${FILESDIR}"/${P}-tests.patch