summaryrefslogtreecommitdiff
path: root/dev-python/furo/furo-2024.1.29.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-30 05:49:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-30 05:49:55 +0000
commit73e3b099187df1c4f2df056e45f345a56d2535aa (patch)
tree42fef135111a0d9bb70b2843f3d9158875b891b0 /dev-python/furo/furo-2024.1.29.ebuild
parentb0c85b2635958d1aa7c9cee8dbf22ad871a280f1 (diff)
gentoo auto-resync : 30:01:2024 - 05:49:55
Diffstat (limited to 'dev-python/furo/furo-2024.1.29.ebuild')
-rw-r--r--dev-python/furo/furo-2024.1.29.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/furo/furo-2024.1.29.ebuild b/dev-python/furo/furo-2024.1.29.ebuild
new file mode 100644
index 000000000000..1cf4206b8d7e
--- /dev/null
+++ b/dev-python/furo/furo-2024.1.29.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# sphinx-theme-builder is completely unusable, as it requires pinning
+# to a very-specific nodejs version number, and ofc loves fetching
+# everything from the Internet
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Clean customisable Sphinx documentation theme"
+HOMEPAGE="
+ https://pypi.org/project/furo/
+ https://github.com/pradyunsg/furo/
+"
+SRC_URI="$(pypi_wheel_url)"
+S=${WORKDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-basic-ng[${PYTHON_USEDEP}]
+"
+
+python_compile() {
+ distutils_wheel_install "${BUILD_DIR}/install" \
+ "${DISTDIR}/${P}-py3-none-any.whl"
+}