summaryrefslogtreecommitdiff
path: root/dev-python/funcy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-27 13:58:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-27 13:58:28 +0000
commit8eccda982236f2cfe9188bdcaffd9168134f39a9 (patch)
treea2f9e1db038cdb1c9ae55a8ead0f9020b072d627 /dev-python/funcy
parentf2299aed04cae8310f7fce0be5396370e346d966 (diff)
gentoo auto-resync : 27:01:2023 - 13:58:28
Diffstat (limited to 'dev-python/funcy')
-rw-r--r--dev-python/funcy/Manifest2
-rw-r--r--dev-python/funcy/funcy-1.18.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/funcy/Manifest b/dev-python/funcy/Manifest
index 62250c08c937..21a404678890 100644
--- a/dev-python/funcy/Manifest
+++ b/dev-python/funcy/Manifest
@@ -1,3 +1,5 @@
DIST funcy-1.17.tar.gz 112383 BLAKE2B 150133f72ed165bdc9adc3a9f4954dfd5b846dea7b1ee2cae0d6621ebaec3e2ba986cd6596fd86482036aad6476913caec0868db9cf55c067fdbf62ac10953e2 SHA512 d48ce3b7a7b8ee7512df109d651f40ca4dadf681acca6ab0a4857a2ea408f20f6345b9b416ca8b1e924050a842648192b8fe79381c202361bc4d2e25bd55ad05
+DIST funcy-1.18.tar.gz 277530 BLAKE2B 78e86e23b3908924de1de62dd567ff8ff52079a9a7529923c84f67a3c5f768d232164d758763db1ce941986c28012dbcb3c146412998b1d1d6064efcc0ff4bf9 SHA512 274fec59c1fddc58248b5f8c81686955706333bbd33a1d567f62694c70449ef2488fae6bf76418b8ff3c6655fad12ed344cc6c90a84c5b10412e32fbdda016fe
EBUILD funcy-1.17.ebuild 484 BLAKE2B 570a5c1969cf16e65fb2fc7a840f777f5aa4b9fa95439e05c277f69848929b72a15b9ceb22f5fbd877371e03856d50b555e02c7550ca0fc692d9da8722842c24 SHA512 dc7963bf04635626b278b8011ab47c7e3529ce442d78b7a898721269c57b9abb3641ef19a8f965d9b5565769e3b14afbde67b7dd714a1ecfb0ac215237179234
+EBUILD funcy-1.18.ebuild 552 BLAKE2B 699b6b54df8fb023dec2badd2d3df6301d7befd7dcd2aac6a301e6255e403ed93ecd0695d7db722989a7ac45ef732612447ae025eb0432ee953b53ce313ed44c SHA512 1b46d3735fc095c175aa4d50b241ecd7add50e2b6c6c5e589ec4d92d99ea1934dd11d47aaf39adf4f76d5a6a61629a413754e8c1f9549630bc8dbd606730cabf
MISC metadata.xml 491 BLAKE2B 70c6646bc4496af1ef98d1178b2b4bf9d876ee0a3664e878af184d12b162c9c926d14bd8dd7987355c4bef86ce53fb65ea96abe2384198f2c054c3835e78f982 SHA512 31d13ddb7d20c36c98e5a4068e96881200122425608e8877c133483117b565b44d65800bcc61dc6ad7e407b6c9953a3f53afd52aebd1a5c25aa1ceacc067c744
diff --git a/dev-python/funcy/funcy-1.18.ebuild b/dev-python/funcy/funcy-1.18.ebuild
new file mode 100644
index 000000000000..9a149505ee00
--- /dev/null
+++ b/dev-python/funcy/funcy-1.18.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of fancy functional tools focused on practicality"
+HOMEPAGE="
+ https://github.com/Suor/funcy/
+ https://pypi.org/project/funcy/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/whatever[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest