summaryrefslogtreecommitdiff
path: root/dev-python/fsspec
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-16 12:48:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-16 12:48:38 +0000
commitd08ea43e9ada434f42f4be8e115b67ab22ce38af (patch)
treebdc9f44b886b8b704d67c2417df0b7b2055a2976 /dev-python/fsspec
parent80ea6e6ea87f4685ceff45cd13dd00d644688cac (diff)
gentoo auto-resync : 16:03:2024 - 12:48:37
Diffstat (limited to 'dev-python/fsspec')
-rw-r--r--dev-python/fsspec/Manifest2
-rw-r--r--dev-python/fsspec/fsspec-2024.3.0.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/fsspec/Manifest b/dev-python/fsspec/Manifest
index cda61220f0f1..ae2243d51ca6 100644
--- a/dev-python/fsspec/Manifest
+++ b/dev-python/fsspec/Manifest
@@ -1,3 +1,5 @@
DIST filesystem_spec-2024.2.0.gh.tar.gz 424600 BLAKE2B 548f77229dd936437cbafcd4e8df2a5c25e6244ba5c95553cb84eabbb6d8c2aa16313896b4aecbb6c921d01f84c6c5517b13a2cf1552cac0fa29da8034873143 SHA512 ca8c7c448984ecd9b128608f2c028cf32baf3cda3f22addde80c3bef5c1e5644e010b739fb5d28dc951151fdafb4006def080e8c2c769179b1d145ad6e2f9370
+DIST filesystem_spec-2024.3.0.gh.tar.gz 426296 BLAKE2B 815b8004f5f04e7c831d4b31e0d667b63f9dc13d2ccbb5cd3e33292ec75a8952e4eceaa9e1f2547de3ab53111e1154c9ca36b4e48ea21e3235a409ee00e409b6 SHA512 f6b05e5724cb640a3526b37f6368327788cf87bb9e4a523f79af846aa682dbd193b1699854e8f7c57849ba7a6805a422d56aad77049e4500a5ca2c0966ab183e
EBUILD fsspec-2024.2.0.ebuild 1864 BLAKE2B 1ab257d1015b2cd39be95f6370d4082b1800677667569cef6e269b57c4756f5f931387c31c9267c18dcfd755a3478726e06302b01266a077b0432a2c7393b471 SHA512 0b1adda11b7f1ba26f755f4d4d131eb50e98cac476401d1017ca327e0b6eb678e4d49c89fd4f25b5af14c27a58d46de3dfe410ef8245cae91142b0520beab5b9
+EBUILD fsspec-2024.3.0.ebuild 1867 BLAKE2B 3dcc46a24b0d5b8ba7e10e75719df33974fb9c021df2216080e446f0690c2874f8a006c87bc927bf3662e9aaf97447876695885419672ff413ede9e7d6db1aa3 SHA512 d7d1f4a35239f5b75bf347492a1b6e3f5859994f4e77b3b2289850293542a08b77f5f8f2983450684985426df7098c6215fcb2aeb41ee36589e3c7c4ad05411f
MISC metadata.xml 374 BLAKE2B 6c0b18a0ad3b85713ae6f618ac0646ed63f08549bd7d1ed5bd94b80d89d79efaf2f97ce913a0a7d6e54e77cc602994416520a22deadcc71e484cf7ca22bc6dde SHA512 5bf051387d6bcffb3022d023f60ee8f76ca277bb8d626dda988a0baaf1d1e3a71e872d8316607ee7e269e579b5a17c23ab93c56fade533150171d3ce44e4bb71
diff --git a/dev-python/fsspec/fsspec-2024.3.0.ebuild b/dev-python/fsspec/fsspec-2024.3.0.ebuild
new file mode 100644
index 000000000000..68c6f4a4b1af
--- /dev/null
+++ b/dev-python/fsspec/fsspec-2024.3.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=filesystem_spec-${PV}
+DESCRIPTION="A specification that python filesystems should adhere to"
+HOMEPAGE="
+ https://github.com/fsspec/filesystem_spec/
+ https://pypi.org/project/fsspec/
+"
+SRC_URI="
+ https://github.com/fsspec/filesystem_spec/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+# Note: this package is not xdist-friendly
+distutils_enable_tests pytest
+
+src_test() {
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ fsspec/tests/test_spec.py::test_find
+ # requires s3fs
+ fsspec/implementations/tests/test_local.py::test_urlpath_inference_errors
+ fsspec/tests/test_core.py::test_mismatch
+ # requires pyarrow, fastparquet
+ fsspec/implementations/tests/test_reference.py::test_df_single
+ fsspec/implementations/tests/test_reference.py::test_df_multi
+ )
+
+ local EPYTEST_IGNORE=(
+ # sftp and smb require server started via docker
+ fsspec/implementations/tests/test_dbfs.py
+ fsspec/implementations/tests/test_sftp.py
+ fsspec/implementations/tests/test_smb.py
+ # unhappy about dev-python/fuse-python (?)
+ fsspec/tests/test_fuse.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -p pytest_mock -o tmp_path_retention_policy=all
+}