summaryrefslogtreecommitdiff
path: root/dev-python/fsspec
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-02 22:43:17 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-02 22:43:17 +0000
commit44f7bdd4803ecacf7943d21fdf2531eb2ea9aeff (patch)
tree4710102399c8e8f01d716ea1139c8fd2db449d7d /dev-python/fsspec
parent417ef5d7c7bd36af15766ab14554600fbe7daed7 (diff)
gentoo auto-resync : 02:02:2025 - 22:43:16
Diffstat (limited to 'dev-python/fsspec')
-rw-r--r--dev-python/fsspec/Manifest2
-rw-r--r--dev-python/fsspec/fsspec-2025.2.0.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/fsspec/Manifest b/dev-python/fsspec/Manifest
index 806ff5aa2f5c..e9591e9c5b5c 100644
--- a/dev-python/fsspec/Manifest
+++ b/dev-python/fsspec/Manifest
@@ -1,3 +1,5 @@
DIST filesystem_spec-2024.12.0.gh.tar.gz 421670 BLAKE2B f6e6f2b478f89c9fbad6822149dc9a2b868fd2fee6edfbd532471b23d49248360170323e9454cc803c4096e62d8957e4ecaf1062bce3cdce005b39af94fdf52c SHA512 9e506da2c81a603350ecea7745b98fa38727bd0f176dc587dd570cab0e27650cd77ac061dce190d6b6372bb5dc4d5a0f3beb59b831a11a1392e178e6c94ab872
+DIST filesystem_spec-2025.2.0.gh.tar.gz 422445 BLAKE2B 7a834edb2577cbb2ff75512f8c880113bd5809526aaafebddfbdc96e0b562fb5935e630a21958150d62370d13c41a73094d966ea84132c858c6d0e83e9150fc9 SHA512 193a0824eac8fc751ae7e81dfae65e0839060b491dcd538ab4ca0454ea60952b4b602fc1987bc4890595aa5751326745342f2c1359327d5d949c62bf198be04a
EBUILD fsspec-2024.12.0.ebuild 1505 BLAKE2B bb76dabdaaea1a2b53aacb284d0426dd9bffd6fae59f6f053c695569aaba2a1b291f8a90f586952b1a1267795b53e646e62c59f96847597afc30038166677003 SHA512 cd366efbcb519e59e4e4df335b0d4e70edf5e7f0ea53d5bf6774a4803a2b72978a32e7f7bf807eb08e9734a49662d3772ebaffa9c203418207d078c91fe23276
+EBUILD fsspec-2025.2.0.ebuild 1508 BLAKE2B 75a4530d7d0f4d5309cdc1a27034a9dc56380f22f53d3c463db6f1b93b758887075a0d0a4f402c01452ec1ad1846d616c46455787c31046b1d723d0b93194a18 SHA512 5d9b899588d66f8eadc1657ae418b21762d5dc0c54313070b733f5e1dd51a0d5486327474df8ff7e6c291ae625e5ddef9a4c7fa9e84d68f9dc08c9d31e25b51e
MISC metadata.xml 374 BLAKE2B 6c0b18a0ad3b85713ae6f618ac0646ed63f08549bd7d1ed5bd94b80d89d79efaf2f97ce913a0a7d6e54e77cc602994416520a22deadcc71e484cf7ca22bc6dde SHA512 5bf051387d6bcffb3022d023f60ee8f76ca277bb8d626dda988a0baaf1d1e3a71e872d8316607ee7e269e579b5a17c23ab93c56fade533150171d3ce44e4bb71
diff --git a/dev-python/fsspec/fsspec-2025.2.0.ebuild b/dev-python/fsspec/fsspec-2025.2.0.ebuild
new file mode 100644
index 000000000000..eb22ae1267a8
--- /dev/null
+++ b/dev-python/fsspec/fsspec-2025.2.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2020-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=filesystem_spec-${PV}
+DESCRIPTION="A specification that python filesystems should adhere to"
+HOMEPAGE="
+ https://github.com/fsspec/filesystem_spec/
+ https://pypi.org/project/fsspec/
+"
+# upstream removed tests in 2024.6.0
+SRC_URI="
+ https://github.com/fsspec/filesystem_spec/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+# Note: this package is not xdist-friendly
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+src_test() {
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ fsspec/implementations/tests/test_reference.py::test_async_cat_file_ranges
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -p pytest_mock -o tmp_path_retention_policy=all
+}