summaryrefslogtreecommitdiff
path: root/dev-python/fs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /dev-python/fs
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'dev-python/fs')
-rw-r--r--dev-python/fs/Manifest3
-rw-r--r--dev-python/fs/fs-2.4.9-r1.ebuild53
-rw-r--r--dev-python/fs/fs-2.4.9.ebuild2
3 files changed, 56 insertions, 2 deletions
diff --git a/dev-python/fs/Manifest b/dev-python/fs/Manifest
index 224da4ec4b24..4dc7443d4f88 100644
--- a/dev-python/fs/Manifest
+++ b/dev-python/fs/Manifest
@@ -1,3 +1,4 @@
DIST fs-2.4.9.tar.gz 126022 BLAKE2B bd7406ee0c22171af349bed6096f58bc749af30f3fae6b8532d7a2b07dd7f0a55165f4b4ab413d6ff7c8861fbe7784ae383a984d26c1cdb1bdc9100c4ae0b0df SHA512 594536eccc043547df4ec4fd1fc507d3fad2838ebb46768a11f142c68d42a776f9fa3cda8651421c6255314835a0283407ea49ebdce04af84a1646efaf5391e5
-EBUILD fs-2.4.9.ebuild 1377 BLAKE2B e56a1e7366edcf0de888abefa183d4b187465188051224996665e321d498c00d235915779eff06f0ec8d0959a83bbe4b0df7da208855928d02c419de8d8c1524 SHA512 5f4c01b935dc51b57528b36e8ee10ff15ae2329632c4ab2543f19c5d69d70251cd0a7bbfae0110626acc2ca827d06d98b8660efc7310e7f75919f2ade3b31faa
+EBUILD fs-2.4.9-r1.ebuild 1387 BLAKE2B 01462723d75efca38d1a5265b5374f38f5317b9b58f2314b7c54f656cc3baf5e438a455f9364bfd2c98ff3232f02241e6582cacc9aa3187e7220344e17aa21e0 SHA512 4964cd47da3a6f9402e48cdad771dc4cc9fc610604cfb8ac96e4c338f8a819ed1a132e2602a04ee403caf1a122c1fb3520380fb07f6c54e4a3aa1bed423df4de
+EBUILD fs-2.4.9.ebuild 1376 BLAKE2B 45b632ac7d1b5eced7f0de3f32bd14568423aa001af745fe316567c67f269383abc6869b8022cf70aeb6ec99db37520e349d69f70bbd1a74c756f8f23567e8d3 SHA512 c8123c0669b7146439444a44e1ff12f65f3b951bb4df2323873e93a22f3a8aba845a16874f154a05e3222fc31d1012733a6ffe25bb6489b552e3d197a4f01302
MISC metadata.xml 486 BLAKE2B 69d62d79b3d0e05fb12bbf8a4d4f703f82488cace87e8f42aaace9319c18f564c3c841b5b69a189530ffb760bceb1acb9fce38472af659a6c4ce24b1bddc16c0 SHA512 48e48fb5f3c868fb8e1b9dce7c483c13291659c99e0f19e096204451e1ada83fb0d2334d89a3beb45de11b7e710a3deb9e5777e5c8f905312efe899cbee02d07
diff --git a/dev-python/fs/fs-2.4.9-r1.ebuild b/dev-python/fs/fs-2.4.9-r1.ebuild
new file mode 100644
index 000000000000..7bc6c8c04459
--- /dev/null
+++ b/dev-python/fs/fs-2.4.9-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Filesystem abstraction layer"
+HOMEPAGE="
+ https://pypi.org/project/fs/
+ https://docs.pyfilesystem.org
+ https://www.willmcgugan.com/tag/fs/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/appdirs-1.4.3[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="test? (
+ $(python_gen_cond_dep '
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyftpdlib[${PYTHON_USEDEP}]
+ dev-python/pysendfile[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ ' -3)
+)"
+
+python_test() {
+ # python2_7 tests require dev-python/typing which is
+ # now in stdlib so ignore tests. py2.7 is going away.
+ if python_is_python3; then
+ esetup.py test || die "tests failed"
+ fi
+}
+
+pkg_postinst() {
+ optfeature "S3 support" dev-python/boto
+ optfeature "SFTP support" dev-python/paramiko
+ optfeature "Browser support" dev-python/wxpython
+}
diff --git a/dev-python/fs/fs-2.4.9.ebuild b/dev-python/fs/fs-2.4.9.ebuild
index 654b838c0c5b..a68ebf6c8e9f 100644
--- a/dev-python/fs/fs-2.4.9.ebuild
+++ b/dev-python/fs/fs-2.4.9.ebuild
@@ -16,7 +16,7 @@ SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
IUSE="test"
RESTRICT="!test? ( test )"