summaryrefslogtreecommitdiff
path: root/dev-python/frozenlist
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-09 15:26:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-09 15:26:14 +0000
commit116b320513d92b6d49648834e8d5a043cd757feb (patch)
tree1eef0875165c4402e6dc1db35681158aed9786ca /dev-python/frozenlist
parentfc2c8b325a27d1dd0e181a50517601b4fde8aa7f (diff)
gentoo auto-resync : 09:11:2022 - 15:26:14
Diffstat (limited to 'dev-python/frozenlist')
-rw-r--r--dev-python/frozenlist/Manifest2
-rw-r--r--dev-python/frozenlist/frozenlist-1.3.3.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/frozenlist/Manifest b/dev-python/frozenlist/Manifest
index d2d33d74d5f6..23834c7d9d55 100644
--- a/dev-python/frozenlist/Manifest
+++ b/dev-python/frozenlist/Manifest
@@ -1,3 +1,5 @@
DIST frozenlist-1.3.1.gh.tar.gz 27705 BLAKE2B 7428d936926978acb90a857e0f76b303dddea684c3e815b3fd583e888102e114cc629fcd8e862a4e72775f8525193becfd4b9cd844a36f5b2c7964605008bb84 SHA512 4986f3635ebd2d3ca9623299a66375b03938a7be72f7a1d3437b1bf8c0739513942e6babf00476b61055c9ebee3638ec807dad521c52990104d4d57017efdfb2
+DIST frozenlist-1.3.3.gh.tar.gz 27742 BLAKE2B cf0dcd2ed0e22cb7fa3d57a73177e53cace8e6301c462ab56544678f1f78f113ac3ad9ffb68dafb3ae957a1e52e2069dcec76b5adc27284587d614bbb6a8c139 SHA512 8f416996c18d352912e88dad6b503cb1e5ce566d69e97aad8d7eedc6415316e8c9e63eb2c341c5d2409ebf90fd58153ce642d5d88f277435bc6e5a4f1ce8b949
EBUILD frozenlist-1.3.1.ebuild 951 BLAKE2B 34f0f1ccfea43960817d487f3db1b0a8e898ab2540da1603e63d502dd08ad773a03164ad625264a4eb927f8d5102aee16861bdb62dfd207432025f1f3bb26967 SHA512 481e569cd7f6694cab015085efa0ae9f87daa608c6f9f6aeae6887ede168461fa31383c30d3690beb9b02bc074bad9334b9cb009c6c0d65eeef446177cadb988
+EBUILD frozenlist-1.3.3.ebuild 959 BLAKE2B a747d4160ba57a6412a86fbe8e00daec54ae331c306e541609eab5b5ad5bdb601b31741409340a0cab25cbf89ae9cf46073351c390dfd36e6dbb0644502b0fcc SHA512 8bf36bdb8951eebb9e69080c8bf443b8c71f19f8ca361163c426c60b5814a4fc2bd186779d5befb905243bb5312da8c451130666d89101519a850dd43ba9bfdf
MISC metadata.xml 351 BLAKE2B 354fa5d9789eb9f28cfe13a39e80f5ba41f4ef9f8daa3437cbab5f1fb61074baf9d1a196814cb459c0a1d3b3c1fbe806ee77580023d71b8b8c6314ad23405765 SHA512 a5b647914f9a7b2004bb3e1c02a6fe07dcaad58dda503cb6a41d6735dcfe80c4e60e4ca51ba83110557518e23f01a656f05266553a6b5acfe95a0560ecb2829e
diff --git a/dev-python/frozenlist/frozenlist-1.3.3.ebuild b/dev-python/frozenlist/frozenlist-1.3.3.ebuild
new file mode 100644
index 000000000000..f8146bda6935
--- /dev/null
+++ b/dev-python/frozenlist/frozenlist-1.3.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A list-like structure which implements collections.abc.MutableSequence"
+HOMEPAGE="
+ https://pypi.org/project/frozenlist/
+ https://github.com/aio-libs/frozenlist/
+"
+SRC_URI="
+ https://github.com/aio-libs/frozenlist/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ' 'python*')
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/addopts/d' pytest.ini || die
+ distutils-r1_src_prepare
+}
+
+python_configure() {
+ # pypy is not using the C extension
+ if [[ ${EPYTHON} == python* ]]; then
+ > .install-cython || die
+ emake cythonize
+ fi
+}