summaryrefslogtreecommitdiff
path: root/dev-python/frozendict
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-14 14:25:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-14 14:25:52 +0100
commita6b284ce6cc4682e2f879616e915f11774a183ac (patch)
tree53c864b622355c5dd667a6822e3c280dcfbad76a /dev-python/frozendict
parent53b3135150fc3b8f4831f8cc9d83276228e94916 (diff)
gentoo auto-resync : 14:08:2022 - 14:25:52
Diffstat (limited to 'dev-python/frozendict')
-rw-r--r--dev-python/frozendict/Manifest6
-rw-r--r--dev-python/frozendict/frozendict-2.3.2.ebuild8
-rw-r--r--dev-python/frozendict/frozendict-2.3.4.ebuild29
-rw-r--r--dev-python/frozendict/metadata.xml4
4 files changed, 41 insertions, 6 deletions
diff --git a/dev-python/frozendict/Manifest b/dev-python/frozendict/Manifest
index e8f4f716427f..948d28582fcf 100644
--- a/dev-python/frozendict/Manifest
+++ b/dev-python/frozendict/Manifest
@@ -1,3 +1,5 @@
DIST frozendict-2.3.2.gh.tar.gz 306318 BLAKE2B 3bc10f34784a8b76b7c6ca0eeccc8331e9a558f0e24d2328550eb5a985ed2ad6c94d027c51ee44f2d25af67fc453356e01b5cfee773880b87d73c55113ca10b2 SHA512 8dc88a3e7898be8fbced16fbdbdee469d07ecbb06a059512f98f71e50a8c5f2c3a4f3d4e6aa06bab121e4ae2e9cea76f6d89c73212047069f2ef88c616c7278a
-EBUILD frozendict-2.3.2.ebuild 633 BLAKE2B 2a45c4f6d4488ef934b87d0e3351d01d9897ffc4d70215bbf985fc64e22cf3eb004286948223f46df5d4a701381d1f3a45a2dc9a32825aa32f8a870a0a643e64 SHA512 a9d27f4daaafdda45d608c327dfe34d1f63ea60ad98291aec53ebca94fc74605efa5b5809c0ea5e0b1f7dc617f4554ffaf40e693c12a5922ea8783fb7a86e69b
-MISC metadata.xml 533 BLAKE2B ba17bdaf9d30d16cf97728129e16da896c21f8ffe938a3e068a85899a3ccfa36acb1d071ab70c4a3a28d05e082708890864f370d95beee344af1e65e0d144ae9 SHA512 62a4439f0b6d4658191118dd7ca5e9e09600b3f92af456aaddf7244d4be591d48f82ed7f479829e2efe96f55e1131b6a38302705d4f76ddec2ddef4865d9b1ea
+DIST frozendict-2.3.4.gh.tar.gz 307399 BLAKE2B ac6311182ed2ba4925a14a145b4d30a0241978f55ae7a81cebc534ede812ca77097f0f8c7eeb08e8cbd6240e036d3b5035bd3e9b284a55b638c93717e3a20258 SHA512 15acc4fceb5e2228ee3423d4a5b86c529e9bdcb7264f59139cbde6194983901a17da8036bebf53d7d8057ce52666031e90eb1ca358bfd374c651fd60743988dc
+EBUILD frozendict-2.3.2.ebuild 587 BLAKE2B 419c535aad7c96ba24618822df7d70e69c9bc8ed156adb571de5bcd52b2f11042cd3268c67953ebe599c9f0754229a7e44e833373ca91b76cf7c950f13dc8dfa SHA512 c937c5c58d872a48cadc1def6c60d5142c2161f58ad23b75d5114bed302242edc4b2d1ab29f59aac8bd789d804871d5edb53d391197db51316ffffab280f1e33
+EBUILD frozendict-2.3.4.ebuild 589 BLAKE2B 3b96e1e4738df9501d4c451578d093de5c47d8913645f9f0589ce456f84edb276480979969d808bb45f351f62e8325d2daf66af3737ec498409a6698f4fee32e SHA512 c1f41ddf47dc45cdec9b6bd2702f96e4829b77ae3db7839af3f0931ae4c4e907de238ec0bcf6f58fff65b7d2d98481ec7f778ca482077e1dfb58811467344f97
+MISC metadata.xml 634 BLAKE2B 362d9aef54a08943047b2f7b04f74d142be6eb74c74d8242460a70e22a3d77d475f588057fbca3ec6f691f2516a52bc23016e694824d092470670e05e98a79d6 SHA512 7f452c4e377081a16c159ca73079a73666dbd862f237516cb3962bfa7a8c4d32f6c68c7bcd5ef37cade10b999fd026178ca2192bd8254d37da642c9bec81137c
diff --git a/dev-python/frozendict/frozendict-2.3.2.ebuild b/dev-python/frozendict/frozendict-2.3.2.ebuild
index bf424c54eba1..371501d7202e 100644
--- a/dev-python/frozendict/frozendict-2.3.2.ebuild
+++ b/dev-python/frozendict/frozendict-2.3.2.ebuild
@@ -21,7 +21,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc64"
-# few tests fail with python3_9 and one with python3_10
-RESTRICT="test"
-
-distutils_enable_tests pytest
+python_test() {
+ cd "${T}" || die
+ epytest "${S}/test"
+}
diff --git a/dev-python/frozendict/frozendict-2.3.4.ebuild b/dev-python/frozendict/frozendict-2.3.4.ebuild
new file mode 100644
index 000000000000..fa692c82ed56
--- /dev/null
+++ b/dev-python/frozendict/frozendict-2.3.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple immutable mapping for python"
+HOMEPAGE="
+ https://github.com/Marco-Sulla/python-frozendict/
+ https://pypi.org/project/frozendict/
+"
+SRC_URI="
+ https://github.com/Marco-Sulla/python-frozendict/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+python_test() {
+ cd "${T}" || die
+ epytest "${S}/test"
+}
diff --git a/dev-python/frozendict/metadata.xml b/dev-python/frozendict/metadata.xml
index f556e15b09bb..06170b580da7 100644
--- a/dev-python/frozendict/metadata.xml
+++ b/dev-python/frozendict/metadata.xml
@@ -9,6 +9,10 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
<upstream>
<remote-id type="pypi">frozendict</remote-id>
<remote-id type="github">Marco-Sulla/python-frozendict</remote-id>