summaryrefslogtreecommitdiff
path: root/dev-python/frozendict
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-python/frozendict
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-python/frozendict')
-rw-r--r--dev-python/frozendict/Manifest3
-rw-r--r--dev-python/frozendict/frozendict-2.3.2.ebuild27
-rw-r--r--dev-python/frozendict/metadata.xml16
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/frozendict/Manifest b/dev-python/frozendict/Manifest
new file mode 100644
index 000000000000..3bf7e29ffb1c
--- /dev/null
+++ b/dev-python/frozendict/Manifest
@@ -0,0 +1,3 @@
+DIST frozendict-2.3.2.gh.tar.gz 306318 BLAKE2B 3bc10f34784a8b76b7c6ca0eeccc8331e9a558f0e24d2328550eb5a985ed2ad6c94d027c51ee44f2d25af67fc453356e01b5cfee773880b87d73c55113ca10b2 SHA512 8dc88a3e7898be8fbced16fbdbdee469d07ecbb06a059512f98f71e50a8c5f2c3a4f3d4e6aa06bab121e4ae2e9cea76f6d89c73212047069f2ef88c616c7278a
+EBUILD frozendict-2.3.2.ebuild 626 BLAKE2B e7bfaa07deeb8362a984a5417ad1e1aa99c33303cef66f0bab7880050af28ec0c9557f99f2f6101ae2a6c9b4692f2bbcdc97549ad9e4fb8dee02405e9f49199b SHA512 f69afcd187675991efbe5338a76d58008a607bcd2aa7086de30f0cdbabda3ae94f1d9e5ffe7ca0c2aa798c3f9ff1a821406d5168b42350d15c3f1c33b8e4114f
+MISC metadata.xml 533 BLAKE2B ba17bdaf9d30d16cf97728129e16da896c21f8ffe938a3e068a85899a3ccfa36acb1d071ab70c4a3a28d05e082708890864f370d95beee344af1e65e0d144ae9 SHA512 62a4439f0b6d4658191118dd7ca5e9e09600b3f92af456aaddf7244d4be591d48f82ed7f479829e2efe96f55e1131b6a38302705d4f76ddec2ddef4865d9b1ea
diff --git a/dev-python/frozendict/frozendict-2.3.2.ebuild b/dev-python/frozendict/frozendict-2.3.2.ebuild
new file mode 100644
index 000000000000..28a3b265a196
--- /dev/null
+++ b/dev-python/frozendict/frozendict-2.3.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple immutable mapping for python"
+HOMEPAGE="
+ https://github.com/Marco-Sulla/python-frozendict
+ https://pypi.python.org/pypi/frozendict
+"
+SRC_URI="https://github.com/Marco-Sulla/python-frozendict/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+S="${WORKDIR}/python-${P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# few tests fail with python3_9 and one with python3_10
+RESTRICT="test"
+
+distutils_enable_tests pytest
diff --git a/dev-python/frozendict/metadata.xml b/dev-python/frozendict/metadata.xml
new file mode 100644
index 000000000000..f556e15b09bb
--- /dev/null
+++ b/dev-python/frozendict/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>arkamar@atlas.cz</email>
+ <name>Petr Vaněk</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">frozendict</remote-id>
+ <remote-id type="github">Marco-Sulla/python-frozendict</remote-id>
+ </upstream>
+</pkgmetadata>