summaryrefslogtreecommitdiff
path: root/dev-python/fritzconnection
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-13 11:06:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-13 11:06:03 +0100
commitbe8708090362c01c6111c4b76f1e395c14d86e00 (patch)
treebb61ca73e867522450783849eb63c9e1f0ba1730 /dev-python/fritzconnection
parente93a38d535f2c29b55a5756d2de99425986b0bf3 (diff)
gentoo auto-resync : 13:08:2024 - 11:06:03
Diffstat (limited to 'dev-python/fritzconnection')
-rw-r--r--dev-python/fritzconnection/Manifest2
-rw-r--r--dev-python/fritzconnection/fritzconnection-1.14.0.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/fritzconnection/Manifest b/dev-python/fritzconnection/Manifest
index b2604e789905..b8a658b20899 100644
--- a/dev-python/fritzconnection/Manifest
+++ b/dev-python/fritzconnection/Manifest
@@ -1,3 +1,5 @@
DIST fritzconnection-1.13.2.gh.tar.gz 161752 BLAKE2B 9cd4af3ebaa3d617560ab833e4702b05d3bd6c8356242b4269506847760dad57c7f1d900d7da3092f4e07eb33c86f082c7d3dbc8179919b97422ad5eab78ef01 SHA512 c5e8566d2fde0b789269944df3c08f5cfb4b04ea4c91e5fc06eb97c6598f64b50b50778479948cb34c3a26d872e4d7c324a92791c3f593ec503a126d3b055062
+DIST fritzconnection-1.14.0.gh.tar.gz 165234 BLAKE2B 8a9350ad632eef353d08acd19560ffaed5d0cbfb073881f8892242b6616e1b830c84c7e9236280068278bac459a43f53c140a2f4d474ce9787a064530a8531b0 SHA512 99d002365d425ce459a3cfe9bbf48680639ccb1ef1cea65870a39e684c712abb8be16d10dad2c1a529c8b27c7b15dd9dad4a9eff38c975b1d8ff2fb15af72aa3
EBUILD fritzconnection-1.13.2-r1.ebuild 1543 BLAKE2B 3597d2dd6a17744f69d3ab17dcad43cb77eca72957a9d908a3f9661a99b0b12b1bec53290040897e15e99f7dfbd403183e030571435e32a91294ce5133f9c59d SHA512 a7cdae22a7530c3deae2096663b192f80a15cdde2ca7300ee5b44ca80a683005592be7427c29d570ba87b9200f708bc068c2c2363b736e2f4c9595e1dd37ee2b
+EBUILD fritzconnection-1.14.0.ebuild 1543 BLAKE2B 3597d2dd6a17744f69d3ab17dcad43cb77eca72957a9d908a3f9661a99b0b12b1bec53290040897e15e99f7dfbd403183e030571435e32a91294ce5133f9c59d SHA512 a7cdae22a7530c3deae2096663b192f80a15cdde2ca7300ee5b44ca80a683005592be7427c29d570ba87b9200f708bc068c2c2363b736e2f4c9595e1dd37ee2b
MISC metadata.xml 588 BLAKE2B 775577c995b833db6ed7e09a04f46496a6881043c63d72135f958ebc7e5387db93bc56f8ac3d0b99c1182eb03f21101e160c6df34798a7aa87aa5802d4459779 SHA512 5372a1a81cd10e31b1d32a53974fb7808773d6b6156411065d230890d2cfebc723e211f0a778cb5ccb8fd8957f3f99665f6f6093326cbda1c5f3245d3fe2bfdd
diff --git a/dev-python/fritzconnection/fritzconnection-1.14.0.ebuild b/dev-python/fritzconnection/fritzconnection-1.14.0.ebuild
new file mode 100644
index 000000000000..58059b742c1b
--- /dev/null
+++ b/dev-python/fritzconnection/fritzconnection-1.14.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Lib/tool to communicate with AVM FRITZ! devices using TR-064 protocol over UPnP"
+HOMEPAGE="
+ https://github.com/kbr/fritzconnection/
+ https://pypi.org/project/fritzconnection/
+"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="qrcode"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/kbr/fritzconnection"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/kbr/fritzconnection/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+RDEPEND="
+ >=dev-python/requests-2.22[${PYTHON_USEDEP}]
+ qrcode? (
+ dev-python/segno[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # flaky (relies on time.sleep(0.01) magically being sufficient)
+ fritzconnection/tests/test_fritzmonitor.py::test_terminate_thread_on_failed_reconnection
+ )
+
+ if has_version "dev-python/segno[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ # requires "QR Code detection" support in media-libs/opencv
+ # https://bugs.gentoo.org/917121
+ fritzconnection/tests/test_fritzwlan.py::test_get_wifi_qr_code
+ fritzconnection/tests/test_fritzwlan.py::test_helper_functions
+ fritzconnection/tests/test_fritzwlan.py::test_tools
+ )
+ fi
+
+ # "routertest" marks tests against live hardware
+ epytest -m "not routertest"
+}